summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-20 12:24:24 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-20 16:33:11 +0100
commit9019567428de9a21c8e302dfef4391af0c9f2fab (patch)
treefa37a00fea661c6323b89fa6ec2fe07497f9e1b6 /dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild
parentdev-ros/diagnostic_updater: Bump to 1.10.3. (diff)
downloadgentoo-9019567428de9a21c8e302dfef4391af0c9f2fab.tar.gz
gentoo-9019567428de9a21c8e302dfef4391af0c9f2fab.tar.bz2
gentoo-9019567428de9a21c8e302dfef4391af0c9f2fab.zip
dev-ros/rosdiagnostic: Bump to 1.10.3.
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild')
-rw-r--r--dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild b/dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild
new file mode 100644
index 000000000000..e28046b6462d
--- /dev/null
+++ b/dev-ros/rosdiagnostic/rosdiagnostic-1.10.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command to print aggregated diagnostic contents to the command line"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+"
+RDEPEND="${DEPEND}"