summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-16 17:30:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-16 18:03:34 +0200
commite4a970b2bbf284847d4313b6ddb7e9081fb0aebb (patch)
treeb4b30270cf49a7369ecf9165fdea095ea5f9fe2f /dev-qt
parentdev-qt/qtnetwork: drop 5.15.10-r2 (diff)
downloadgentoo-e4a970b2bbf284847d4313b6ddb7e9081fb0aebb.tar.gz
gentoo-e4a970b2bbf284847d4313b6ddb7e9081fb0aebb.tar.bz2
gentoo-e4a970b2bbf284847d4313b6ddb7e9081fb0aebb.zip
dev-qt/qtwayland: drop 5.15.10-r3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/files/qtwayland-5.15.10-Destroy-frame-queue-before-display.patch43
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.10-r3.ebuild56
3 files changed, 0 insertions, 100 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index bdd8925e2519..65de0537ac9c 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,4 +1,3 @@
-DIST qtwayland-5.15.10-gentoo-kde-1.tar.xz 42480 BLAKE2B 3902ecb713b8f35922b0d19bef0b2ec340ca52feb4b61de629dfa6b344d7f550de3e509e265f4476eb907f78b55d5c50c21d9dfeeb7e2e8f680a43fffc911ed4 SHA512 6a131ca2db008a2d224ee6733f47d05a455a8487d38b45cf63882e98e2c29d8163ac5d2f2c2e043f03103bada6e212b5d33cbf11677f8ca2b86fdbf02fc2b239
DIST qtwayland-5.15.10-gentoo-kde-2.tar.xz 43076 BLAKE2B 735ac875c0957de47f90d08931eaaaf8d53b1db0012c7d0a592c78ae78da56ffc8a1ba9bbac0577a78d4c05a92a22acef51a6afc95db54bea2d1a2a9658b67c4 SHA512 e0131bb1f2a09597a85d1d8a402bcb1d529cbc44f62e9be8dd8eba9c10007ca4f83572ca48052529b2325cdd8d886abed1f96ba4e00768e4b1c2febe1eb5ef91
DIST qtwayland-everywhere-opensource-src-5.15.10.tar.xz 568552 BLAKE2B c5cd4ed5ff78befb5bb49f9eb809562c418b2469aa0fa23728a1de46d57f42788bba3f87a54c8dda2ee0900c76b84213d1111fd86159dc5e6707f7b67ed386de SHA512 214b1fec7dfd815d148a7485f7811e623b06d172e58e4ee3167264a4e4b8f4aeec11474e574f91652a0bd3a48476a6747cad468f1e5035c49a55a96fc1400899
DIST qtwayland-everywhere-src-6.5.2.tar.xz 1059356 BLAKE2B 4708b78ff5c8e413edaa4d4400317f58dd068273a5eef7caf1500abf8afbe4e9ac405b6854691ef93265a7eeb0cfb7406024826a0b7c7ba3f8149218af67fd48 SHA512 520d109402f1d629481029a3b1eaab740e66135db4069c34651172bb2ad821b22de60e9956a96331d2f32a4522fc52c6a4ba99b474092d755760cad08c776477
diff --git a/dev-qt/qtwayland/files/qtwayland-5.15.10-Destroy-frame-queue-before-display.patch b/dev-qt/qtwayland/files/qtwayland-5.15.10-Destroy-frame-queue-before-display.patch
deleted file mode 100644
index 1fdf08dc7487..000000000000
--- a/dev-qt/qtwayland/files/qtwayland-5.15.10-Destroy-frame-queue-before-display.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-https://bugs.gentoo.org/910315
-https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/73
-
-Reported downstream in Gentoo at https://bugs.gentoo.org/910315.
-
-`kde/5.15` has b981fc82eb37700353949c72d3fd6d0887c8c107 ('[PATCH 27/51] Reduce memory leakage')
-backported but this introduces a use-after-free because `wl_event_queue_destroy` must be called
-before `wl_display_disconnect`. So, just backport the upstream fix which sorts out the order.
-
-Upstream review: https://codereview.qt-project.org/c/qt/qtwayland/+/471416
-Upstream review (6.x): https://codereview.qt-project.org/c/qt/qtwayland/+/471528
-
-From 3a8613b91d2239aebc73b43562f929aa71af0de5 Mon Sep 17 00:00:00 2001
-From: David Redondo <qt@david-redondo.de>
-Date: Tue, 11 Apr 2023 14:27:27 +0200
-Subject: [PATCH] Destroy frame queue before display
-
-wl_event_queue_destroy accesses the display.
-Found by running a test under valgrind.
-
-Pick-to: 6.5
-Change-Id: Ic89cbd3b6e98b4fc9561b0e63b5fab4886a1ec50
-Reviewed-by: David Edmundson <davidedmundson@kde.org>
-(cherry picked from commit a76bf824fcd1cc3789f0d3454a0423c0241d9718)
---- a/src/client/qwaylanddisplay.cpp
-+++ b/src/client/qwaylanddisplay.cpp
-@@ -379,11 +379,12 @@ QWaylandDisplay::~QWaylandDisplay(void)
- #if QT_CONFIG(cursor)
- qDeleteAll(mCursorThemes);
- #endif
-- if (mDisplay)
-- wl_display_disconnect(mDisplay);
-
- if (m_frameEventQueue)
- wl_event_queue_destroy(m_frameEventQueue);
-+
-+ if (mDisplay)
-+ wl_display_disconnect(mDisplay);
- }
-
- // Steps which is called just after constructor. This separates registry_global() out of the constructor
---
-2.41.0
diff --git a/dev-qt/qtwayland/qtwayland-5.15.10-r3.ebuild b/dev-qt/qtwayland/qtwayland-5.15.10-r3.ebuild
deleted file mode 100644
index cab77b1950fc..000000000000
--- a/dev-qt/qtwayland/qtwayland-5.15.10-r3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} != *9999* ]]; then
- QT5_KDEPATCHSET_REV=1
- KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
-fi
-
-inherit qt5-build
-
-DESCRIPTION="Wayland platform plugin for Qt"
-
-SLOT=5/${QT5_PV} # bug 815646
-IUSE="vulkan X"
-
-DEPEND="
- dev-libs/wayland
- =dev-qt/qtcore-${QT5_PV}*:5=
- =dev-qt/qtdeclarative-${QT5_PV}*:5=
- =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
- media-libs/libglvnd
- vulkan? ( dev-util/vulkan-headers )
- X? (
- =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
- x11-libs/libX11
- x11-libs/libXcomposite
- )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="dev-util/wayland-scanner"
-
-PATCHES=(
- # QTBUG-97037, pending upstream:
- # https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/71
- "${FILESDIR}/${PN}-5.15.9-fix-mouse-stuck-in-pressed-state-after-DnD.patch"
- # bug #910315, pending upstream:
- # https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/73
- "${FILESDIR}/${P}-Destroy-frame-queue-before-display.patch"
-)
-
-src_configure() {
- local myqmakeargs=(
- --
- $(qt_use vulkan feature-wayland-vulkan-server-buffer)
- $(qt_use X feature-xcomposite-egl)
- $(qt_use X feature-xcomposite-glx)
- )
- qt5-build_src_configure
-}
-
-src_install() {
- qt5-build_src_install
- rm "${D}${QT5_BINDIR}"/qtwaylandscanner || die
-}