summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-22 19:56:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-22 20:08:17 +0100
commit3287cc19284fdcaf352a98a1d41c4ff853503bd6 (patch)
treeccd0f513d3cd4d6c5425717914113a82f64ec14f /dev-qt/qtwayland
parentdev-qt/qtlocation: drop 5.15.14 (diff)
downloadgentoo-3287cc19284fdcaf352a98a1d41c4ff853503bd6.tar.gz
gentoo-3287cc19284fdcaf352a98a1d41c4ff853503bd6.tar.bz2
gentoo-3287cc19284fdcaf352a98a1d41c4ff853503bd6.zip
dev-qt/qtwayland: client: use current modifiers in repeat keys
See also: https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/84 QTBUG: https://bugreports.qt.io/browse/QTBUG-123007 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.16-r1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 0e57b5e87f36..7a78f1a18cae 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,5 +1,6 @@
DIST qtwayland-5.15.14-gentoo-kde-1.tar.xz 47472 BLAKE2B 3812e5f18bcb857cf3c76cf8a53525a84b14bc4cf8430f4339c1ef9a5d6208dcdfba3f052bcc80c6ad8815db2415207e2eb5ed07bbf9e7076be675f2a4cee3c0 SHA512 912bc902e4f9d945dac396c75a2af9896e3002535a51e6b5b07166c38b9d6ea073da3d93db07742a0db295dd5f8167fdef351230adcb2145704c36b576c0f5e3
DIST qtwayland-5.15.16-gentoo-kde-1.tar.xz 46556 BLAKE2B 909188979333e27277d589255caa617c3eb02d66f82cea3ee546b48e5dcb95d30a107379d6db4ca40118bda4d6fe8dcf5e1686b15f381bf51579483d6ce8a549 SHA512 01e0358ad649d7834f54068bd064e4a8982f1fa36c9b00619b862ff2c85bcb82d13293204ee0d69a8c3ad10c090db0f72dee5fc1f7b1034c9fd2d2f26ae01f56
+DIST qtwayland-5.15.16-gentoo-kde-2.tar.xz 47116 BLAKE2B 30646c02214167b1891b84873f7d10812d3aa1894db1a246771a2df2a799d1768c857a623153d862e15f6a7ed7b784738c8afdc5f4968e57a7e2296735d69876 SHA512 c3af344eb647fb16f1237387345ee4e56e2efa7376f10d46d09de34c77add092cb50acf29d180fa61ab33331fee959ab187339b05b6fa0b9d4fda6f0c28b600b
DIST qtwayland-everywhere-opensource-src-5.15.14.tar.xz 560916 BLAKE2B a5edb21446348f20e6f65736b402c3075a4bde0d7fa02c24cbfc5de65739ca8d7ac2186bd17a995bfb3de23106e696e2b1321dc3ae401984bdafaa3479c9aa1e SHA512 9e8add52353f7a146759511c49c001cd76a56790a81af5222f6f2d3d1a2f1ee9cc62048c72efe69708eb3444c6115272d4af8d738df7b1e1da959359d7420dbb
DIST qtwayland-everywhere-opensource-src-5.15.16.tar.xz 561148 BLAKE2B a095051245e0ba0f0a27c7da703628e67b30465e12de06c1662dea3a3d74163cc67baa004f0cbab01bf5b70c6d2bdea289278859b2713a00f595cc51bb6f654a SHA512 9ce2bca54aa0e17be17383fccd6caca721db5b54f8905ec86cf871ed0e2414e6bc86878b9cc5167c322153467076b2afdcd6163a8fb2feb6b19cef11c3a29247
DIST qtwayland-everywhere-src-6.7.2.tar.xz 1123220 BLAKE2B 70c2d8942afc4e1629d2ef34b6c062ecb5800185bb37e150c1d66a5216606028d2f59668991bddb5036572c962e92c3658d336167a7f9ffbf3d2f4d609a771f9 SHA512 2cd4f45f05ae60bc7f82b94f2e9c217ee4b8322f60381e1b079b90e0687e51cfbeb10b5dd724e1cca7e422b1b101d2b91c0ee47b1a732411cef330fb052c97c2
diff --git a/dev-qt/qtwayland/qtwayland-5.15.16-r1.ebuild b/dev-qt/qtwayland/qtwayland-5.15.16-r1.ebuild
new file mode 100644
index 000000000000..3c3da7bc65be
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.16-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=2
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+SLOT=5/${QT5_PV} # bug 815646
+IUSE="compositor vulkan"
+
+RDEPEND="
+ dev-libs/wayland
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=]
+ media-libs/libglvnd
+ x11-libs/libxkbcommon
+ compositor? ( =dev-qt/qtdeclarative-${QT5_PV}*:5= )
+"
+DEPEND="${RDEPEND}
+ vulkan? ( dev-util/vulkan-headers )
+"
+BDEPEND="dev-util/wayland-scanner"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ -no-feature-xcomposite-egl
+ -no-feature-xcomposite-glx
+ $(qt_use compositor feature-wayland-server)
+ $(qt_use compositor feature-wayland-dmabuf-server-buffer)
+ $(qt_use compositor feature-wayland-drm-egl-server-buffer)
+ $(qt_use compositor feature-wayland-shm-emulation-server-buffer)
+ )
+
+ use compositor && myqmakeargs+=(
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ )
+
+ qt5-build_src_configure
+}
+
+src_install() {
+ qt5-build_src_install
+ rm "${D}${QT5_BINDIR}"/qtwaylandscanner || die
+}