summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-06-04 02:14:26 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-06-04 15:30:40 -0400
commit02dc02aa172de8de55b8e6267f693d23f71508e7 (patch)
treecb422b2f9332ba6fd820e6cd4d23765f721303a9 /dev-qt/qtwayland
parentdev-qt/qttools: update live for 6.8+ branch (diff)
downloadgentoo-02dc02aa172de8de55b8e6267f693d23f71508e7.tar.gz
gentoo-02dc02aa172de8de55b8e6267f693d23f71508e7.tar.bz2
gentoo-02dc02aa172de8de55b8e6267f693d23f71508e7.zip
dev-qt/qtwayland: update live for 6.8+ branch
USE=gnome choice may debatable given this does not depend on gnome, but it does nothing ootb unless gnome is detected and is intended to integrate better with it. Alternatively could've done USE=adwaita or USE=gnome-integration and enable it manually on gnome profiles but does not feel necessary. fwiw keep a local USE description to clarify. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/metadata.xml1
-rw-r--r--dev-qt/qtwayland/qtwayland-6.9999.ebuild7
2 files changed, 7 insertions, 1 deletions
diff --git a/dev-qt/qtwayland/metadata.xml b/dev-qt/qtwayland/metadata.xml
index 1509a2e738a9..69ca9f641c1c 100644
--- a/dev-qt/qtwayland/metadata.xml
+++ b/dev-qt/qtwayland/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="compositor">Enable support for the wayland compositor / server APIs</flag>
+ <flag name="gnome">Build the GNOME-like decoration plugin (loaded by default with GNOME)</flag>
<flag name="qml">Build QML/QtQuick bindings and imports</flag>
<flag name="vulkan">Enable support for Vulkan-based server buffer integration</flag>
</use>
diff --git a/dev-qt/qtwayland/qtwayland-6.9999.ebuild b/dev-qt/qtwayland/qtwayland-6.9999.ebuild
index dc3ce8575fd3..93ba392322f1 100644
--- a/dev-qt/qtwayland/qtwayland-6.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-6.9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-IUSE="accessibility compositor qml vulkan"
+IUSE="accessibility compositor gnome qml vulkan"
RDEPEND="
dev-libs/wayland
@@ -21,6 +21,10 @@ RDEPEND="
compositor? (
qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
)
+ gnome? (
+ ~dev-qt/qtbase-${PV}:6[dbus]
+ ~dev-qt/qtsvg-${PV}:6
+ )
"
DEPEND="
${RDEPEND}
@@ -41,6 +45,7 @@ src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Quick)
$(qt_feature compositor wayland_server)
+ $(qt_feature gnome wayland_decoration_adwaita)
)
qt6-build_src_configure