summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-17 05:55:22 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-17 07:21:12 +0100
commitee35dc643179b97cefedfb87d684b6d57eb9d14f (patch)
treec84a6020fb829cfeefcebe372a520df7b96c094f /dev-python
parentvirtual/dist-kernel: Bump to 5.10.168 (diff)
downloadgentoo-ee35dc643179b97cefedfb87d684b6d57eb9d14f.tar.gz
gentoo-ee35dc643179b97cefedfb87d684b6d57eb9d14f.tar.bz2
gentoo-ee35dc643179b97cefedfb87d684b6d57eb9d14f.zip
dev-python/botocore: Bump to 1.29.73
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.73.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 79138cc9e1b9..871197690972 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.29.69.gh.tar.gz 11140109 BLAKE2B 5a91e6d425f4a5f424f95fd9bcd893c
DIST botocore-1.29.70.gh.tar.gz 11145631 BLAKE2B 9f1d65e7ecb0c2b436a6260613f7d7cdcf3a01b563042e1dd6997a308f0b7179582f11447b0e3785c2cf8c801bc920f3a850c9b290a78a183bf910189a705732 SHA512 28b375ab94619872d0e9d4331caa687ddaa24c6cce8a66af887dfb308583ff8ad1cb5d78cadc50eb69fcd5ddd50fc1c94b70f128f9ae83ad166596140c45ea81
DIST botocore-1.29.71.gh.tar.gz 11142820 BLAKE2B bc33e29023b95e1482e094173898952bd2e3335ca641416ac4ba5e608b2146333e347aa7fcb7a23dd9c3d5dbc8a092fd2345c91a74b49a9f8b08477e64798c18 SHA512 48a851434e35391e56bb3a8a803291287535a7d15d3b5b1a83c253b0bba1ca3621bd6da5e027ee0485f52eebbce523d1962fb660850663a6b19814e17be443af
DIST botocore-1.29.72.gh.tar.gz 11147118 BLAKE2B ad72456166933dcb540ed7f4fc622c7e1ef1601846b102372bc990e9985699de82da5b629043fc975e287a49cc65383c0adc97737ff831ccb4ea569c148593bf SHA512 64af7f0efe667a175119030cf30524ad09cc29c8447026875286ec2706e6f3fbb2beb90f300675dac27532407a5439d5a0e3d967841b5a58d76f079cdbc99577
+DIST botocore-1.29.73.gh.tar.gz 11152779 BLAKE2B 5324b720e9cd00f51a8722679b2c0edd98cddbff4c940c864ddbda42804c45b7b0f6b720d1ecdb2d41b53c37c19cc2894d93e4906f1bc9bfda07dffa721b5fb2 SHA512 a226f20eaafd3ef40264999e6604475a86b6a538f5435d12c3f0474363288e6abbe0a2e8068296ce5afcdfbbc24c56991718f7fc12edbdc399938d57a70003d8
diff --git a/dev-python/botocore/botocore-1.29.73.ebuild b/dev-python/botocore/botocore-1.29.73.ebuild
new file mode 100644
index 000000000000..0f4daaa48e81
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.73.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}