summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-09-15 20:53:47 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-09-16 06:33:19 +0200
commit885e6890e0f5ba9d14daf0d8b4c750b8a6ed461d (patch)
tree3d060467a43346382ca53ba9487e11bbccec94e1 /dev-python
parentdev-python/autoprop: new package (diff)
downloadgentoo-885e6890e0f5ba9d14daf0d8b4c750b8a6ed461d.tar.gz
gentoo-885e6890e0f5ba9d14daf0d8b4c750b8a6ed461d.tar.bz2
gentoo-885e6890e0f5ba9d14daf0d8b4c750b8a6ed461d.zip
dev-python/vecrec: new package
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17560 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/vecrec/Manifest1
-rw-r--r--dev-python/vecrec/metadata.xml16
-rw-r--r--dev-python/vecrec/vecrec-0.3.0.ebuild23
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/vecrec/Manifest b/dev-python/vecrec/Manifest
new file mode 100644
index 000000000000..da37cb051d39
--- /dev/null
+++ b/dev-python/vecrec/Manifest
@@ -0,0 +1 @@
+DIST vecrec-0.3.0.tar.gz 118946 BLAKE2B 04ecb6be616b0d65e93feb3e238f068e68d95a2d90e9ab7c0b0aaf3d257924cf14f46cf403661b26b74691ed41afad9f16c52b426da23e0209d8849fe01bf42b SHA512 9208bacac7e32380fce3d0e3fca8b3353776d4154ffe2eb2360020f76eace5ced38ad30253cad377716c9a0979ee0d038debd0e6187bc72caeb17505225597b5
diff --git a/dev-python/vecrec/metadata.xml b/dev-python/vecrec/metadata.xml
new file mode 100644
index 000000000000..655f8bd3f846
--- /dev/null
+++ b/dev-python/vecrec/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ Python-FCL is an (unofficial) Python interface for the Flexible Collision Library (FCL), an excellent C++
+ library for performing proximity and collision queries on pairs of geometric models.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kxgames/vecrec</remote-id>
+ <remote-id type="pypi">vecrec</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/vecrec/vecrec-0.3.0.ebuild b/dev-python/vecrec/vecrec-0.3.0.ebuild
new file mode 100644
index 000000000000..daf91a08356c
--- /dev/null
+++ b/dev-python/vecrec/vecrec-0.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="2D vector and rectangle classes"
+HOMEPAGE="https://github.com/kxgames/vecrec
+ https://pypi.org/project/vecrec/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv tests || die "Tests fail with ${EPYTHON}"
+}