summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-21 06:30:17 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-21 06:40:23 +0100
commit349f5f66ef7e9d151bb5dae69f9ac3526b86e556 (patch)
treec5c9083e3717cb90bc1ae96b00bf7d46252d8ed4 /dev-python
parentdev-python/google-api-python-client: Bump to 2.154.0 (diff)
downloadgentoo-349f5f66ef7e9d151bb5dae69f9ac3526b86e556.tar.gz
gentoo-349f5f66ef7e9d151bb5dae69f9ac3526b86e556.tar.bz2
gentoo-349f5f66ef7e9d151bb5dae69f9ac3526b86e556.zip
dev-python/aiohttp-socks: Bump to 0.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aiohttp-socks/Manifest1
-rw-r--r--dev-python/aiohttp-socks/aiohttp-socks-0.9.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/aiohttp-socks/Manifest b/dev-python/aiohttp-socks/Manifest
index 83e49df98eef..b8271e8d7902 100644
--- a/dev-python/aiohttp-socks/Manifest
+++ b/dev-python/aiohttp-socks/Manifest
@@ -1 +1,2 @@
DIST aiohttp-socks-0.9.0.gh.tar.gz 13590 BLAKE2B 1fb13b8607a9245d872d0ad45f50860492132c661d1a0f52fb846e56568d784f1545abab8f08bb2bd633460033f85982c80979c880841ccc40bcc0b2ae3f2ba4 SHA512 c19b8325270cbb660d9200e84c34a4c753097cdb282397bc31261c7082e184c947cab7821f63d326881f0ac4bb4104a813ebb8fc2b3df663f8891da246f0c789
+DIST aiohttp-socks-0.9.1.gh.tar.gz 13699 BLAKE2B 9d6f86fdb767b286f72b6b6a9c7c7abd5a4ee05f52bfe5c94830ee477a12cd1c97572e31acdb05ca8ea0d70a5a12bd23afff7b946859e7de3fa8ce4cfdafd18e SHA512 dd4f5c2a8a7c7af6d46293fd0213fedd3f75c0cf36b96c776aa05f7e1433d2032c7927f1b10cf74d801e5e294bd0cde066562abcd8b196aeb0e1c58a88de0423
diff --git a/dev-python/aiohttp-socks/aiohttp-socks-0.9.1.ebuild b/dev-python/aiohttp-socks/aiohttp-socks-0.9.1.ebuild
new file mode 100644
index 000000000000..da83dfcce838
--- /dev/null
+++ b/dev-python/aiohttp-socks/aiohttp-socks-0.9.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS proxy connector for aiohttp"
+HOMEPAGE="
+ https://pypi.org/project/aiohttp-socks/
+ https://github.com/romis2012/aiohttp-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/aiohttp-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.4.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/tiny-proxy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest