summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-10 05:11:37 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-10 05:35:02 +0100
commit1dbac6d12a33333be2fdb29f88e4d859c53baf14 (patch)
treebad7568f5bc3030734edc21cbc4cce1f70c76034 /dev-python
parentdev-python/pytools: Bump to 2024.1.20 (diff)
downloadgentoo-1dbac6d12a33333be2fdb29f88e4d859c53baf14.tar.gz
gentoo-1dbac6d12a33333be2fdb29f88e4d859c53baf14.tar.bz2
gentoo-1dbac6d12a33333be2fdb29f88e4d859c53baf14.zip
dev-python/pytest-subtests: Bump to 0.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-subtests/Manifest1
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.14.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index 9e7d4a367aeb..21b014265ae4 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1,2 +1,3 @@
DIST pytest_subtests-0.13.1.tar.gz 15936 BLAKE2B 6301c0dae6eccd9f20acf6c08e0b1b77c7e80a64e4558628cc85e0d6c202d0b2bb0d7be27f930d7bf68ab8c4c2076e7fe68ab24b9b45cb22fbb3a4b31fd7b4e7 SHA512 c1c92a7a608710fd75a3a67cfd620ec257d7b1fa191fc4788a747ffebdf3973dde9407ed85e1842f15947558f6ec7c15e5c13ad84ce59489398386d6578f1caf
DIST pytest_subtests-0.14.0.tar.gz 17363 BLAKE2B 3b0ebe86b0acd1e2f00c75f11a2d04f8269774ca44f2b55b337a2c1d68da9d1636e5c159e4e554c21f27f8a80adc91dd36bee7d8f2ec359340e9cc5de0edd702 SHA512 53306f887fdd500226991394624fac06c60dd1339e8689f041f5b14ee6ad75470a08cca48230dab774f04d75f5ae5a63c2f3f08231e5ae61a7d928f6e23781b6
+DIST pytest_subtests-0.14.1.tar.gz 17632 BLAKE2B 5a9013e1126ce921b1cc5932e2e743827f382f2566fb573c75bc040e806dd64e196a1c49ad1e4eabf13925ed82e68749e6d842f0d03098ab6bce4857134c581e SHA512 f79afa0747334ad885e4e592b2b4ff1381d00fb282ab24c785afe681120e2a9670dbcd7627bd9041cd24922a96146d8be30f0e221b4a6ee8bef8aa7b52038544
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.14.1.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.14.1.ebuild
new file mode 100644
index 000000000000..ebae62a6a9f0
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.14.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.4[${PYTHON_USEDEP}]
+"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_subtests.plugin
+ epytest
+}