summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-15 20:34:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-15 20:34:22 +0200
commit05f54ba7f08fb7bba862ccbc1a0d161c0f186323 (patch)
treeafa43932dfca40ae115dbefe3911fc6a79ac5241 /dev-python
parentdev-python/emoji: Remove old (diff)
downloadgentoo-05f54ba7f08fb7bba862ccbc1a0d161c0f186323.tar.gz
gentoo-05f54ba7f08fb7bba862ccbc1a0d161c0f186323.tar.bz2
gentoo-05f54ba7f08fb7bba862ccbc1a0d161c0f186323.zip
dev-python/idna: Bump to 3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/idna/Manifest1
-rw-r--r--dev-python/idna/idna-3.10.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/idna/Manifest b/dev-python/idna/Manifest
index 1c45df586a23..3965bf89bd9a 100644
--- a/dev-python/idna/Manifest
+++ b/dev-python/idna/Manifest
@@ -1 +1,2 @@
+DIST idna-3.10.tar.gz 190490 BLAKE2B 887d92fd54b2f55b33856fcb9af3d6541a8cb28b9d49d1ee621dac7e1597ad5d2370000d6bfd895d5e515b4b6837949b5085fb391f283c375ffe4529072a8dd6 SHA512 bdc00fb42c48a34ec3df91b0592fe41785061f891a252ce82f168d99089a52e8e5bc7a823794f61e7915c0f691d911ed8b3bf7aecf3e2aeb3fc85da4ef35f47e
DIST idna-3.8.tar.gz 189467 BLAKE2B e70c754f3a76807d2df9df09b19ec9ea8e98de19f81741dfbb2f828ebd0ac6385e2c0d2fab83206b4c592b40f0b785ed0078eafc0d0339cd9ff53440051c511d SHA512 5ea57a0e21621722375b8b3b90831c1e367f738d7d96d27143990d25ef26d374bcd306956a785ebe6283445642c39b8f655ab4de4b407055e350d11012acdb62
diff --git a/dev-python/idna/idna-3.10.ebuild b/dev-python/idna/idna-3.10.ebuild
new file mode 100644
index 000000000000..2e79cc472163
--- /dev/null
+++ b/dev-python/idna/idna-3.10.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="
+ https://github.com/kjd/idna/
+ https://pypi.org/project/idna/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests unittest