summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-11 21:07:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-11 21:23:30 +0200
commit044359350437ebd8c06652fbfdb63dd47efd44e4 (patch)
tree183f578a878e9db8460e6bfc2fabcc9907ade1b6 /dev-python
parentnet-mail/notmuch: require older sphinx (diff)
downloadgentoo-044359350437ebd8c06652fbfdb63dd47efd44e4.tar.gz
gentoo-044359350437ebd8c06652fbfdb63dd47efd44e4.tar.bz2
gentoo-044359350437ebd8c06652fbfdb63dd47efd44e4.zip
dev-python/denonavr: Bump to 0.10.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/denonavr/Manifest1
-rw-r--r--dev-python/denonavr/denonavr-0.10.8.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index 08c706c62926..e82185694928 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1,2 +1,3 @@
DIST denonavr-0.10.6.tar.gz 124692 BLAKE2B f0af92e0160d0533389e69dfad5740c432d52b3b6446288a572ef62aa9c8610397d3d8d5770ce6b46b4ad224b2782fc8a63a4f548a4237251d52695f5b4dde95 SHA512 336183e04e2f3f98faa1878a472ce69cc2fe7519398b34a61126cd6539ae6e40c60329d5b2f914e3dc85a9dbb11a1eb8fe9669f4e2910838d5ffcee0da7633c5
DIST denonavr-0.10.7.tar.gz 148282 BLAKE2B a5168c1b00ce1e8223d619a8e2e7ae663fa913d673b6f62580daf57ff76d8da4306681d92df0e32e612376038255bc52e25a1f59dd5f6a429685c8bd9146d843 SHA512 6667edeb4272ce909f8bc2dfa51b31d78915ae6085064bbf0f53714f8b473e0fad24eb6484a10abb093ef27d59faeaebdffdb55eadb03f8b64e864642364a791
+DIST denonavr-0.10.8.tar.gz 148387 BLAKE2B 1ad6687655abe70e6f83119c893187efe88143521e5c91987ae6b3d393fe7a327bf34941d87a4ba37107ef415493471be0630a1f3c643f94cfb3e22460c80806 SHA512 fea1b2a03d83d520c837323939db503879ec0c973bbf9409087298977f4d07f8ed8b25c2d287c1529786a4e42cd59b0f0708a8a4b7df3d5f630967110d7fe906
diff --git a/dev-python/denonavr/denonavr-0.10.8.ebuild b/dev-python/denonavr/denonavr-0.10.8.ebuild
new file mode 100644
index 000000000000..744cc8df1076
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.10.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="https://github.com/scarface-4711/denonavr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/asyncstdlib[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/netifaces[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest