summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-06 08:02:17 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-06 08:08:46 +0100
commitd0a74fef6e36f3adcf220854ccdf0205f510b01a (patch)
treea5299872e8e4b02a9da9d9a19c0043dba3354817 /dev-python/xvfbwrapper
parentdev-python/xstatic: Remove py2 (diff)
downloadgentoo-d0a74fef6e36f3adcf220854ccdf0205f510b01a.tar.gz
gentoo-d0a74fef6e36f3adcf220854ccdf0205f510b01a.tar.bz2
gentoo-d0a74fef6e36f3adcf220854ccdf0205f510b01a.zip
dev-python/xvfbwrapper: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xvfbwrapper')
-rw-r--r--dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild5
1 files changed, 1 insertions, 4 deletions
diff --git a/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild b/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
index 49aebade00d5..d097e1b308e8 100644
--- a/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
+++ b/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
inherit distutils-r1
@@ -13,11 +13,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="x11-base/xorg-server[xvfb]"
-BDEPEND="test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
python_test() {
"${PYTHON}" -m unittest discover || die "Tests failed with ${EPYTHON}"