summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-16 04:56:07 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-16 05:03:00 -0700
commit6f9379515e5b137b713dd213a2baf4f4e56ff172 (patch)
tree49b3cfb9c58ae8d9622d2b7983251231c82a9d3d /dev-python/xvfbwrapper
parentdev-python/xcffib: version bump to 0.9.0 (diff)
downloadgentoo-6f9379515e5b137b713dd213a2baf4f4e56ff172.tar.gz
gentoo-6f9379515e5b137b713dd213a2baf4f4e56ff172.tar.bz2
gentoo-6f9379515e5b137b713dd213a2baf4f4e56ff172.zip
dev-python/xvfbwrapper: bump to EAPI 7 and add py38 support
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/xvfbwrapper')
-rw-r--r--dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild b/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
index 9c4b8f613007..68eea6876d33 100644
--- a/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
+++ b/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
inherit distutils-r1
@@ -17,9 +17,7 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="x11-base/xorg-server[xvfb]"
-DEPEND="${RDEPEND}
- test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )
-"
+BDEPEND="test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
python_test() {
"${PYTHON}" -m unittest discover || die "Tests failed with ${EPYTHON}"