summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-15 09:42:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-15 10:14:58 +0200
commit7ac961a57dc11895bcecea65e17f89d5cafdf809 (patch)
treee81895877bd345d8a553ab52c3a07766ae0c95e8 /dev-python/webob
parentdev-python/bottle: Enable py3.13 (diff)
downloadgentoo-7ac961a57dc11895bcecea65e17f89d5cafdf809.tar.gz
gentoo-7ac961a57dc11895bcecea65e17f89d5cafdf809.tar.bz2
gentoo-7ac961a57dc11895bcecea65e17f89d5cafdf809.zip
dev-python/webob: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/webob')
-rw-r--r--dev-python/webob/webob-1.8.7-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/webob/webob-1.8.7-r2.ebuild b/dev-python/webob/webob-1.8.7-r2.ebuild
new file mode 100644
index 000000000000..836e74c043c9
--- /dev/null
+++ b/dev-python/webob/webob-1.8.7-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="WebOb"
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="
+ https://webob.org/
+ https://github.com/Pylons/webob/
+ https://pypi.org/project/WebOb/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/legacy-cgi[${PYTHON_USEDEP}]
+ ' 3.13)
+"
+
+distutils_enable_sphinx docs 'dev-python/alabaster'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # py3.9
+ sed -i -e 's:isAlive:is_alive:' tests/conftest.py || die
+ distutils-r1_src_prepare
+}