summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-17 08:04:56 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-17 08:47:37 +0200
commitd38e7e13d9a10b77176d771720da430e4561751a (patch)
treed2c142373944a5f6bd310993186641f840242bd1 /dev-python/wand
parentdev-libs/libgudev: Version bump to 237 (diff)
downloadgentoo-d38e7e13d9a10b77176d771720da430e4561751a.tar.gz
gentoo-d38e7e13d9a10b77176d771720da430e4561751a.tar.bz2
gentoo-d38e7e13d9a10b77176d771720da430e4561751a.zip
dev-python/wand: Bump to 0.6.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wand')
-rw-r--r--dev-python/wand/Manifest1
-rw-r--r--dev-python/wand/wand-0.6.7.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/wand/Manifest b/dev-python/wand/Manifest
index 4dd63a16e71f..ab53b77ba59d 100644
--- a/dev-python/wand/Manifest
+++ b/dev-python/wand/Manifest
@@ -1,2 +1,3 @@
DIST Wand-0.6.5.tar.gz 11477141 BLAKE2B 7257dbee8642d619d69d773aa5e0f70c27e32eb5ca4168746efb191ce6d2a49b000aee07127aa51e1906e52e7bc7f2375f39482edf6a841933e4eb2711217fed SHA512 7355888da6ea604759d4af8548d4c2e08d529c88d2720400bbfc6a19bdb03049f3faa5abcd5f3a9c69b705754e86ad4f511a76a0a310d5dece5c2774d74e543b
DIST Wand-0.6.6.tar.gz 11477246 BLAKE2B e4e908da487994c50b02fb25c7a19a70865fc021e00a36170562dd546ac0d0b9c6eb6d622fc50e0160feb48d52828617d8cf83b1ef0f2f449fdc32f174880917 SHA512 618a8678031b57382d008062ffa21168aeb7afd7a5b82675020b11c756f1542f9a2d2d656d7d683cbf47e4d8be118bf0aac005b4aa1a6e5ae9dc417edea0bd79
+DIST Wand-0.6.7.tar.gz 11686093 BLAKE2B 58abbdc22eb1603ed42e2e2473c0ed2b9026c9c0a499bb885512b56ecf01fb4ffe450979808bba2b4c4466994f86bea9a9c0ced216f8338c845b96a755f39c9f SHA512 e79ecb909f6ad7b3ddae217bb7b27f3c010d22a40eb99866e2a6eb07346000acbead280176e3352da13c20b68a341c751c55d6203bef7968522c8dbcfcab0b06
diff --git a/dev-python/wand/wand-0.6.7.ebuild b/dev-python/wand/wand-0.6.7.ebuild
new file mode 100644
index 000000000000..6f133f63eaa4
--- /dev/null
+++ b/dev-python/wand/wand-0.6.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_P="${PN^}-${PV}"
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="http://wand-py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-gfx/imagemagick"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ epytest --skip-pdf
+}