summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /dev-python/uv
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/uv-0.4.30-r1.ebuild (renamed from dev-python/uv/uv-0.4.30.ebuild)4
-rw-r--r--dev-python/uv/uv-0.5.0-r1.ebuild (renamed from dev-python/uv/uv-0.5.0.ebuild)4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/uv/uv-0.4.30.ebuild b/dev-python/uv/uv-0.4.30-r1.ebuild
index 8ce7f04ec3be..4d826c5cfb40 100644
--- a/dev-python/uv/uv-0.4.30.ebuild
+++ b/dev-python/uv/uv-0.4.30-r1.ebuild
@@ -15,6 +15,8 @@ declare -A GIT_CRATES=(
[version-ranges]='https://github.com/astral-sh/pubgrub;95e1390399cdddee986b658be19587eb1fdb2d79;pubgrub-%commit%/version-ranges'
)
+RUST_MIN_VER="1.80.1"
+
inherit cargo check-reqs
CRATE_PV=${PV}
@@ -60,7 +62,6 @@ RDEPEND="
${DEPEND}
"
BDEPEND="
- >=virtual/rust-1.80
test? (
dev-lang/python:3.8
dev-lang/python:3.9
@@ -84,6 +85,7 @@ pkg_pretend() {
pkg_setup() {
check_space
+ rust_pkg_setup
}
src_prepare() {
diff --git a/dev-python/uv/uv-0.5.0.ebuild b/dev-python/uv/uv-0.5.0-r1.ebuild
index e67a3e7e521e..944b6b4eeafa 100644
--- a/dev-python/uv/uv-0.5.0.ebuild
+++ b/dev-python/uv/uv-0.5.0-r1.ebuild
@@ -15,6 +15,8 @@ declare -A GIT_CRATES=(
[version-ranges]='https://github.com/astral-sh/pubgrub;95e1390399cdddee986b658be19587eb1fdb2d79;pubgrub-%commit%/version-ranges'
)
+RUST_MIN_VER="1.80.1"
+
inherit cargo check-reqs
CRATE_PV=${PV}
@@ -60,7 +62,6 @@ RDEPEND="
${DEPEND}
"
BDEPEND="
- >=virtual/rust-1.80
test? (
dev-lang/python:3.8
dev-lang/python:3.9
@@ -84,6 +85,7 @@ pkg_pretend() {
pkg_setup() {
check_space
+ rust_pkg_setup
}
src_prepare() {