summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-29 19:26:20 +0100
committerSam James <sam@gentoo.org>2021-08-29 19:29:12 +0100
commitd11094516af420d1aac38e1dd978caacd406f88c (patch)
treeb2a77d53db8a87d4085f8e8aee2f5804482cc6e8 /dev-python/utidylib/utidylib-0.7-r1.ebuild
parentapp-accessibility/edbrowse: [QA] revbump for changed RDEPEND (diff)
downloadgentoo-d11094516af420d1aac38e1dd978caacd406f88c.tar.gz
gentoo-d11094516af420d1aac38e1dd978caacd406f88c.tar.bz2
gentoo-d11094516af420d1aac38e1dd978caacd406f88c.zip
dev-python/utidylib: [QA] revbump for changed RDEPEND
It's necessary to have a revision bump for changes in RDEPEND, but especially where we're changing the providers of an any-of || ( ... ) dependency. In this case, if one already has edbrowse installed, once/if tidy-html5 is masked for removal (which seems to be the plan), there's no reason the package manage is obligated to realise that the existing ebuild was modified to allow htmltidy instead. Hence, a revision bump is required to apply the metadata change. Fixes: 4e3e24a192e9d620c7bcbccf536c3c68f04fd363 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/utidylib/utidylib-0.7-r1.ebuild')
-rw-r--r--dev-python/utidylib/utidylib-0.7-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/utidylib/utidylib-0.7-r1.ebuild b/dev-python/utidylib/utidylib-0.7-r1.ebuild
new file mode 100644
index 000000000000..d6947dea0a0e
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.7-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+MY_P="uTidylib-${PV}"
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="https://cihar.com/software/utidylib/ https://pypi.org/project/uTidylib/"
+SRC_URI="https://github.com/nijel/utidylib/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="|| ( app-text/tidy-html5 >=app-text/htmltidy-5.0.0 )"
+DEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+EPYTEST_DESELECT=(
+ # https://github.com/nijel/utidylib/issues/9
+ tidy/test_tidy.py::TidyTestCase::test_missing_load
+)