summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-28 09:50:19 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-28 11:40:49 +0200
commitceb441ba7fd17db4fa7c9704448ebe73ab1fc383 (patch)
tree93d3facd08bb979b1619c0af6bcf0a7a81634882 /dev-python/typeguard
parentdev-libs/collada-dom: fix build with boost-1.85.0 (diff)
downloadgentoo-ceb441ba7fd17db4fa7c9704448ebe73ab1fc383.tar.gz
gentoo-ceb441ba7fd17db4fa7c9704448ebe73ab1fc383.tar.bz2
gentoo-ceb441ba7fd17db4fa7c9704448ebe73ab1fc383.zip
dev-python/typeguard: Fix ignoring mypy tests
Closes: https://bugs.gentoo.org/932865 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/typeguard-4.3.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/typeguard/typeguard-4.3.0.ebuild b/dev-python/typeguard/typeguard-4.3.0.ebuild
index 33595e45784b..4146a24d8dca 100644
--- a/dev-python/typeguard/typeguard-4.3.0.ebuild
+++ b/dev-python/typeguard/typeguard-4.3.0.ebuild
@@ -28,10 +28,9 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
- local EPYTEST_IGNORE=(
- # mypy changes results from version to version
- tests/mypy
- )
+ # mypy changes results from version to version
+ # (we can't use EPYTEST_IGNORE because pytest_ignore_collect breaks it)
+ rm -rf tests/mypy || die
local -x PYTHONDONTWRITEBYTECODE=
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1