summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 11:57:38 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 12:34:07 +0200
commitaae7cdc35ad1a796a762f199f94853bd05215d07 (patch)
treea5b918c06bfefae63fdc37f529bcbacd97e726dc /dev-python/typeguard
parentgames-action/polymc: drop 1.2.2 (diff)
downloadgentoo-aae7cdc35ad1a796a762f199f94853bd05215d07.tar.gz
gentoo-aae7cdc35ad1a796a762f199f94853bd05215d07.tar.bz2
gentoo-aae7cdc35ad1a796a762f199f94853bd05215d07.zip
dev-python/typeguard: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/typeguard-2.13.3-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/typeguard/typeguard-2.13.3-r1.ebuild b/dev-python/typeguard/typeguard-2.13.3-r1.ebuild
new file mode 100644
index 000000000000..b4cdda966b33
--- /dev/null
+++ b/dev-python/typeguard/typeguard-2.13.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/
+"
+SRC_URI="
+ https://github.com/agronholm/typeguard/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # mypy changes results from version to version
+ tests/mypy
+ )
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ epytest
+}