summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-31 16:05:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-31 16:05:29 +0200
commitb847c13e7c9d0a2ec1d93e80fb15490b2070f8fe (patch)
treee1105bd446d5233bd82e1f0bb4544d86ab407c3b /dev-python/twython
parentdev-python/sybil: Remove old (diff)
downloadgentoo-b847c13e7c9d0a2ec1d93e80fb15490b2070f8fe.tar.gz
gentoo-b847c13e7c9d0a2ec1d93e80fb15490b2070f8fe.tar.bz2
gentoo-b847c13e7c9d0a2ec1d93e80fb15490b2070f8fe.zip
dev-python/twython: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/twython')
-rw-r--r--dev-python/twython/twython-3.9.1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/twython/twython-3.9.1.ebuild b/dev-python/twython/twython-3.9.1.ebuild
deleted file mode 100644
index 3562cdc0d51a..000000000000
--- a/dev-python/twython/twython-3.9.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="An easy way to access Twitter data with Python"
-HOMEPAGE="https://github.com/ryanmcgrath/twython"
-SRC_URI="
- https://github.com/ryanmcgrath/twython/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]"
-BDEPEND="
- test? ( dev-python/responses[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # tests are largely unmaintained and outdated
- tests/test_core.py::TwythonAPITestCase::test_get_lastfunction_header_should_return_header
- tests/test_core.py::TwythonAPITestCase::test_request_should_handle_400_for_missing_auth_data
- tests/test_core.py::TwythonAPITestCase::test_request_should_handle_400_that_is_not_auth_related
- tests/test_core.py::TwythonAPITestCase::test_request_should_handle_401
- tests/test_core.py::TwythonAPITestCase::test_request_should_handle_rate_limit
- )
- epytest ${deselect[@]/#/--deselect }
-}