summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-01-19 11:21:48 -0800
committerBrian Dolbec <dolsen@gentoo.org>2018-01-19 14:55:34 -0800
commite687cc64695517d78d20e96039a46623c89599fd (patch)
treeaf0874112a42e356dab832ea619c39dda6a374c4 /dev-python/treq
parentdev-python/sphinx-jinja: Version bump (diff)
downloadgentoo-e687cc64695517d78d20e96039a46623c89599fd.tar.gz
gentoo-e687cc64695517d78d20e96039a46623c89599fd.tar.bz2
gentoo-e687cc64695517d78d20e96039a46623c89599fd.zip
dev-python/treq: Version bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-python/treq')
-rw-r--r--dev-python/treq/Manifest1
-rw-r--r--dev-python/treq/treq-17.8.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/treq/Manifest b/dev-python/treq/Manifest
index 8389d1ff6715..8bfede1339b8 100644
--- a/dev-python/treq/Manifest
+++ b/dev-python/treq/Manifest
@@ -1,3 +1,4 @@
DIST treq-0.2.1.tar.gz 30954 BLAKE2B e7f97fea21c18821db2eba6c26f717cbd83297822e3e607c0a451bd5fc9be1d96200c9780857ac2aa2ce297a5bec681c54c4d3dc18ae3d8f391454e19e744e7e SHA512 d9236c395dca66d358fc9bb1b752e02a7d6335195235808452542de33145057c1c2e959658015b3c89c9a20c35b1a8edb752e151230e72edd313dde6cd6a4cac
DIST treq-16.12.0.tar.gz 43685 BLAKE2B 3d05c41eb0a471e912959546f7e7abf0d8986dcb28b0c36cf1cccfeefd600c3a7141f93650a1b6947665c2ee24cda02ecc8e4ed927b1fb3c36309e23edaea33a SHA512 9385ada8cdf88e608937c118c29506372d8d3a8e7dcdc54998461652f106e4ccca4d6fa0a3f14ff5d9312da7ea1e531a9e4b0772b694b8dbe03f456101d63cca
DIST treq-17.3.1.tar.gz 47380 BLAKE2B 61b51c46252629358c0ffaef7f4e7e2010e2d58c307461caf42982f8b6ad2714af57c37065bdd87a94d2b9e2fde150473b45116f2d8d270f783f20e1a8291020 SHA512 e52cccbfa663314e968b33c58a5be5782063b2d6313a4ee5a03df912146c6ca25abca82915f30791f865afd2c08bb04c9993d9204d876c7ec2b308c6e51cb821
+DIST treq-17.8.0.tar.gz 56439 BLAKE2B 3e39c84453793baf3107c38b656c8968e593845fc0d41035b558326ff947a9e17903ce33dee3157d2cb2f79ab3aa884ddebcd52e743cd6e1ad08a0de324cd6bc SHA512 62933a512fcc8b0e77333eb9268846ad17f4b44cf6ea317ada2565054100be3caf03bda0a1becd775ec85528fc2f5ddec33d23d3579cf484a3c6ba7c71c50a7f
diff --git a/dev-python/treq/treq-17.8.0.ebuild b/dev-python/treq/treq-17.8.0.ebuild
new file mode 100644
index 000000000000..00ad59180b50
--- /dev/null
+++ b/dev-python/treq/treq-17.8.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A requests-like API built on top of twisted.web's Agent"
+HOMEPAGE="https://github.com/twisted/treq https://pypi.python.org/pypi/treq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/incremental[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.4.0[crypt,${PYTHON_USEDEP}]
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+"
+
+DEPEND="${COMMON_DEPEND}
+ doc? ( dev-python/sphinx
+ ${RDEPEND} )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pep8[${PYTHON_USEDEP}]
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C "${S}/docs" html
+}
+
+python_install_all() {
+ use doc && dohtml -r "${S}/docs/_build/html/"*
+ distutils-r1_python_install_all
+}
+
+test_instructions(){
+ ewarn "The 'test' USE flag and FEATURE only ensures that the correct"
+ ewarn "dependenciess are installed for this package."
+ ewarn "Please run eg:"
+ ewarn "$ python3.4 /usr/bin/trial treq"
+ ewarn "as a user for each of the python versions it is installed to"
+ ewarn "to correctly test this package."
+}
+
+python_test() {
+ # Tests fail when run via emerge
+ # they need proper network access
+ test_instructions
+}