summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-06-20 11:56:25 -0400
committerBrian Dolbec <dolsen@gentoo.org>2021-06-20 12:04:32 -0400
commit160133c624208537d264976bdedc12f049f3b01b (patch)
tree831d961e3bb98b5ff0e2cdc526ab4aa5376e3ea0 /dev-python/treq
parentdev-util/buildbot-badges: Version bump to 3.2.0 (diff)
downloadgentoo-160133c624208537d264976bdedc12f049f3b01b.tar.gz
gentoo-160133c624208537d264976bdedc12f049f3b01b.tar.bz2
gentoo-160133c624208537d264976bdedc12f049f3b01b.zip
dev-python/treq: Versiion bump to 21.5.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-python/treq')
-rw-r--r--dev-python/treq/Manifest1
-rw-r--r--dev-python/treq/treq-21.5.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/treq/Manifest b/dev-python/treq/Manifest
index 88277f8c26c6..9e2ad2337ffc 100644
--- a/dev-python/treq/Manifest
+++ b/dev-python/treq/Manifest
@@ -1,2 +1,3 @@
DIST treq-20.9.0.tar.gz 60142 BLAKE2B a495b73221ee86163a5fefd03c8019f4b671a1f32d2ab304b89566339a36aaec7245d33b738b646fa48c42f4db9744938637ece058e067ee3f747e53ce442ab8 SHA512 c595ad69d5a9c688ca966cc897db669a57d14027e0bdc345d550f791390099743749be4a41294e61428cdc7bc0fa197474be780323b00f17a712505e081e7073
DIST treq-21.1.0.tar.gz 71018 BLAKE2B 44223c0ad618f4a57283db60063ee2fd263f958ff18d90b055733fc3bb24c87483a7b833e2210197a4edd003cb3f86647bbb636a9692e5535908b19e0186dba8 SHA512 b68ded90021cb801b276d6310e729a985205bb0701b1d0576b00c6c4efd97400625efffa35763ceef8f0f8d94172cae6fc1abdd3de1c0a4871223d4f06758d89
+DIST treq-21.5.0.tar.gz 71323 BLAKE2B 1e1f0f4c885c1d197fdf9c1a88c9ee486c3fcc4d126498f4ce10e59d62e2445e4935e3f4cabed5de2f2663c3049ab6b49e47a0bad29380a4bb901e30d6723f49 SHA512 81ccfaa90513f0ef53c60f69ff7c60e066c6f0669ab82cf361e0720e5fd3098eb88e9b205f5bb590f1e0cde6083e5e2dfbacb6086986f0dd91fc2b3038da3093
diff --git a/dev-python/treq/treq-21.5.0.ebuild b/dev-python/treq/treq-21.5.0.ebuild
new file mode 100644
index 000000000000..b5f62bffd38c
--- /dev/null
+++ b/dev-python/treq/treq-21.5.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A requests-like API built on top of twisted.web's Agent"
+HOMEPAGE="https://github.com/twisted/treq https://pypi.org/project/treq/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-python/incremental[${PYTHON_USEDEP}]
+ >=dev-python/hyperlink-21.0.0[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.7.0[crypt,${PYTHON_USEDEP}]
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+"
+
+DEPEND="${COMMON_DEPEND}
+ doc? ( dev-python/sphinx
+ ${RDEPEND} )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C "${S}/docs" html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/ )
+
+ distutils-r1_python_install_all
+}
+
+test_instructions() {
+ ewarn "The 'test' USE flag and FEATURE only ensures that the correct"
+ ewarn "dependenciess are installed for this package."
+ ewarn "Please run eg:"
+ ewarn "$ python3.7 /usr/bin/trial treq"
+ ewarn "as a user for each of the python versions it is installed to"
+ ewarn "to correctly test this package."
+}
+
+python_test() {
+ # Tests fail when run via emerge
+ # they need proper network access
+ test_instructions
+}