summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/tlslite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/tlslite')
-rw-r--r--dev-python/tlslite/Manifest1
-rw-r--r--dev-python/tlslite/metadata.xml17
-rw-r--r--dev-python/tlslite/tlslite-0.4.3-r1.ebuild39
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/tlslite/Manifest b/dev-python/tlslite/Manifest
new file mode 100644
index 000000000000..7b6d1a69e098
--- /dev/null
+++ b/dev-python/tlslite/Manifest
@@ -0,0 +1 @@
+DIST tlslite-0.4.3.tar.gz 562090 SHA256 6a67d8a0bec66183719c19c91f383bc1555545055aae4498af2e91fe9d79f813 SHA512 d1f451ebc2f7bd4d5436f1ca8ecfdbaa403f3dbbae9f9ac3900131e5d168e3267e22fcf23d85f87457f06468997cb01a51683d028a67fde58820b15f97689a0c WHIRLPOOL 555f2659f0bb5080519edd5f4325953e13109367ef21e1595816ab4f3956233bb541940f65f2cfa95c041b7f2cc080b8c4ee10719be79edfa11076a2c834fff6
diff --git a/dev-python/tlslite/metadata.xml b/dev-python/tlslite/metadata.xml
new file mode 100644
index 000000000000..74bb6e1c1a1f
--- /dev/null
+++ b/dev-python/tlslite/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ TLS Lite is a free python library that implements SSL 3.0, TLS 1.0, and
+ TLS 1.1. TLS Lite supports non-traditional authentication methods such
+ as SRP, shared keys, and cryptoIDs in addition to X.509 certificates.
+ TLS Lite is pure Python, however it can access OpenSSL, cryptlib,
+ pycrypto, and GMPY for faster crypto operations. TLS Lite integrates
+ with httplib, xmlrpclib, poplib, imaplib, smtplib, SocketServer,
+ asyncore, and Twisted.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">trevp/tlslite</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tlslite/tlslite-0.4.3-r1.ebuild b/dev-python/tlslite/tlslite-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..423598656251
--- /dev/null
+++ b/dev-python/tlslite/tlslite-0.4.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="TLS Lite is a free python library that implements SSL 3.0 and TLS 1.0/1.1"
+HOMEPAGE="http://trevp.net/tlslite/ http://pypi.python.org/pypi/tlslite"
+SRC_URI="http://github.com/trevp/tlslite/downloads/${P}.tar.gz"
+
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+#Refrain for now setting IUSE test and deps of test given test restricted.
+IUSE="doc gmp"
+RESTRICT="test"
+
+DEPEND=">=dev-libs/cryptlib-3.3.3[python,${PYTHON_USEDEP}]
+ || (
+ dev-python/m2crypto[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+ gmp? ( dev-python/gmpy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+# Tests still hang
+python_test() {
+ "${S}"/tests/tlstest.py client localhost:4443 .
+ "${S}"/tests/tlstest.py server localhost:4442 .
+}
+
+python_install_all(){
+ distutils-r1_python_install_all
+ use doc && dohtml -r docs/
+}