summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2018-11-03 17:46:42 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-11-03 23:59:07 +0100
commit38dc91f557a5d69277a16001595df6c2067314dc (patch)
treea78435c32bf9d2ef38ab31e37ee3c8256e55124f /dev-python/texttable
parentdev-python/flask-paginate: new package. (diff)
downloadgentoo-38dc91f557a5d69277a16001595df6c2067314dc.tar.gz
gentoo-38dc91f557a5d69277a16001595df6c2067314dc.tar.bz2
gentoo-38dc91f557a5d69277a16001595df6c2067314dc.zip
dev-python/texttable: bump to 1.5.0.
- Upstream changed to MIT license. Signed-off-by: Joonas Niilola <juippis@gmail.com> Package-Manager: Portage[mgorny]-2.3.49.1 Closes: https://github.com/gentoo/gentoo/pull/10330 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/texttable')
-rw-r--r--dev-python/texttable/Manifest1
-rw-r--r--dev-python/texttable/texttable-1.5.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/texttable/Manifest b/dev-python/texttable/Manifest
index 0fe112fa423c..eed565888b12 100644
--- a/dev-python/texttable/Manifest
+++ b/dev-python/texttable/Manifest
@@ -1,2 +1,3 @@
DIST texttable-0.9.1.tar.gz 11074 BLAKE2B 465738a7b980f2a216d63b268044c1a1b8c0deb986fd398f0ba0ae30ab84020ac6f179b5314a2071592c38443f9cb86387b9ed573342533af9e825000472ebe5 SHA512 7ec37336ef4b253879d0232dcdb4500cad33ecce1067dd7ea26c221dc2c003ee56360bdbd1dd1e00133301c51c67fb2fe9b1703628804a65f2a6ab8a1e830e50
DIST texttable-1.4.0.tar.gz 12274 BLAKE2B 558d905a65a340843a18b9c0987a34b45a53335478bc29275b4150642e8902f77830a63654a177e0017e3c729ea1bcd63d8f2296866773dfbf31cda6bc785ef7 SHA512 41d1b429ee32cd717d273152da0263cfff13d79aae7ecc69bda455c1391ea1e6cf74b412e6043bf3d32d62932b4498a2484deb997ef545fdd6195fd5ebd58fc5
+DIST texttable-1.5.0.tar.gz 10640 BLAKE2B 54bc7f1ac1860e2b88de092528134f8ba63b4f31f621a32e64a242b5f2d3132294818cff6bfdb848d4fa002d515069448dd077a95fa70bdf4e9266e162bb9355 SHA512 f4727947a302c8e1bf09ba08d73f79f083304b42f86f2f181a98f44602961e0b280aedd4e38660630671eac17e6eb92403b89c1ae6ea3cdd3cf861c122b904a3
diff --git a/dev-python/texttable/texttable-1.5.0.ebuild b/dev-python/texttable/texttable-1.5.0.ebuild
new file mode 100644
index 000000000000..3b68d79f45a7
--- /dev/null
+++ b/dev-python/texttable/texttable-1.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5..7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for creating simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cjk test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )
+ )
+"
+RDEPEND="cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -vv tests.py || die
+}