summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-15 11:08:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-15 12:11:21 +0200
commit778a1c298cedd66efeea422b4a88dbf807e06135 (patch)
tree0281f007374d2630fd9a8468b44b0658702b77d4 /dev-python/testfixtures
parentdev-ruby/ruby-ldap: update upstream metadata (diff)
downloadgentoo-778a1c298cedd66efeea422b4a88dbf807e06135.tar.gz
gentoo-778a1c298cedd66efeea422b4a88dbf807e06135.tar.bz2
gentoo-778a1c298cedd66efeea422b4a88dbf807e06135.zip
dev-python/testfixtures: Bump to 7.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-7.2.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index ce6eac7adac5..ca210542b989 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1 +1,2 @@
DIST testfixtures-7.1.0.tar.gz 133026 BLAKE2B 0fbb25e97c06cdd7c94be26c56e96a70847493f71b2f0adc58f333fe2ab930a9bfb6de154a1a23a5cb2cbb1e5e87cb6d9ac95433d357de0689296e33c04078c3 SHA512 d1b2b3ca9674865a45be254a41777c2cba42d4ac3de5d77420d6d33416bfde7ba6a8ca39033cd2c217b0eb81ef5c97bf5b197dd047f9a337bbe1a3da91d9c0ef
+DIST testfixtures-7.2.0.tar.gz 133487 BLAKE2B f5c4ff354d1e2b06a28a947fffe8622e51ed680a29ed6fa3ff5e7e851c21e39ed432d6dc0f5f8c83c6541b0054ca3b2afce960f4a00e1e70619a29f29e03b5ae SHA512 b1b5fdd45509e60db8590ec454659efa42c87f75de9187286d820b5643388f83919ccf3763ec223018a5a5b48821041494982af2016c41e11fe30cabdb909223
diff --git a/dev-python/testfixtures/testfixtures-7.2.0.ebuild b/dev-python/testfixtures/testfixtures-7.2.0.ebuild
new file mode 100644
index 000000000000..b5276e04b446
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-7.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="
+ https://pypi.org/project/testfixtures/
+ https://github.com/Simplistix/testfixtures/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/furo
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
+ )
+
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # https://github.com/simplistix/testfixtures/issues/183
+ docs/comparing.txt::line:790,column:1
+ docs/comparing.txt::line:829,column:1
+ testfixtures/tests/test_tempdirectory.py::TempDirectoryTests::test_as_path_relative_sequence
+ testfixtures/tests/test_tempdirectory.py::TempDirectoryTests::test_as_path_relative_string
+ )
+ ;;
+ esac
+
+ epytest
+}