summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-20 23:59:00 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-21 00:04:02 +0200
commit3749f2be32f9c01e45f8eabe40348d77586afff7 (patch)
tree6f1ed7b5fc133166fd4c3baa44895ab5e951390b /dev-python/subvertpy/subvertpy-0.10.1.ebuild
parentdev-lang/python: Move readline dep outside 'ncurses?' (diff)
downloadgentoo-3749f2be32f9c01e45f8eabe40348d77586afff7.tar.gz
gentoo-3749f2be32f9c01e45f8eabe40348d77586afff7.tar.bz2
gentoo-3749f2be32f9c01e45f8eabe40348d77586afff7.zip
dev-python/subvertpy: Bump to 0.10.1
Closes: https://bugs.gentoo.org/631214
Diffstat (limited to 'dev-python/subvertpy/subvertpy-0.10.1.ebuild')
-rw-r--r--dev-python/subvertpy/subvertpy-0.10.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/subvertpy/subvertpy-0.10.1.ebuild b/dev-python/subvertpy/subvertpy-0.10.1.ebuild
new file mode 100644
index 000000000000..903366b9f458
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.10.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="https://jelmer.uk/code/subvertpy/ https://pypi.org/project/subvertpy"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-vcs/subversion-1.4"
+DEPEND="${RDEPEND}
+ dev-libs/apr-util"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test --args=-v
+}