summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-14 19:41:34 +0100
committerMarek Szuba <marecki@gentoo.org>2020-12-14 19:47:29 +0100
commit2dffe5c65439921204cee6759c87967144b97ff8 (patch)
tree1d26f2a7bb0fab344b95be4b683e723572211276 /dev-python/stomp-py
parentdev-python/pillow: Enable pypy3 (diff)
downloadgentoo-2dffe5c65439921204cee6759c87967144b97ff8.tar.gz
gentoo-2dffe5c65439921204cee6759c87967144b97ff8.tar.bz2
gentoo-2dffe5c65439921204cee6759c87967144b97ff8.zip
dev-python/stomp-py: new package
Python STOMP client library + CLI tool. No tests because running them requires either Docker or carefully setting up several different messaging servers. May or may not support pypy3, for the time being this is blocked by dev-python/docopt. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/stomp-py')
-rw-r--r--dev-python/stomp-py/Manifest1
-rw-r--r--dev-python/stomp-py/metadata.xml12
-rw-r--r--dev-python/stomp-py/stomp-py-6.1.0.ebuild33
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/stomp-py/Manifest b/dev-python/stomp-py/Manifest
new file mode 100644
index 000000000000..36c72ae4158f
--- /dev/null
+++ b/dev-python/stomp-py/Manifest
@@ -0,0 +1 @@
+DIST stomp.py-6.1.0.tar.gz 34690 BLAKE2B bf7ec2899be25bdc373e7d0d73281a6c4aa8b91a05e6ede263f0f9498b2ba3b9bd2c90b0fe472664c930dadf68ccaf09c74b69e7270259c3959396edff04e07b SHA512 73284b5dac8b9ef0d1251cc1059c4b1a545018a39498303d211fd165f0fb80439f2e01f82e18644cfd5d77a4badedcbced57d184ffc7c19f57945e5262f2394a
diff --git a/dev-python/stomp-py/metadata.xml b/dev-python/stomp-py/metadata.xml
new file mode 100644
index 000000000000..53838ba131f5
--- /dev/null
+++ b/dev-python/stomp-py/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">stomp.py</remote-id>
+ <remote-id type="github">jasonrbriggs/stomp.py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/stomp-py/stomp-py-6.1.0.ebuild b/dev-python/stomp-py/stomp-py-6.1.0.ebuild
new file mode 100644
index 000000000000..43324414a605
--- /dev/null
+++ b/dev-python/stomp-py/stomp-py-6.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS="pyproject.toml"
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client library for the STOMP messaging protocol"
+HOMEPAGE="https://pypi.org/project/stomp.py/ https://github.com/jasonrbriggs/stomp.py/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="<dev-python/docopt-0.7.0[${PYTHON_USEDEP}]"
+
+# stomp.py test suite requires quite a few appropriately configured
+# messaging servers (as of 6.1.0: RabbitMQ, ActiveMQ, ActiveMQ Artemis,
+# stompserver). Upstream relies on Docker to provide those servers, however
+# doing the same in src_test would require both granting the portage user
+# extra permissions and packaging the base image (trying to download it
+# on the fly would violate the network sandbox).
+# Side note: PyPI tarballs do not include tests.
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}