summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-11 07:17:45 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-11 07:17:45 +0100
commit6de06424a5c19e98e0e2afe52b08c082e2eafb77 (patch)
tree993fdda8b25e110ed87e7e5ae6833082406e0050 /dev-python/stevedore
parentdev-python/bitarray: Bump to 2.7.1 (diff)
downloadgentoo-6de06424a5c19e98e0e2afe52b08c082e2eafb77.tar.gz
gentoo-6de06424a5c19e98e0e2afe52b08c082e2eafb77.tar.bz2
gentoo-6de06424a5c19e98e0e2afe52b08c082e2eafb77.zip
dev-python/stevedore: Bump to 5.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/Manifest1
-rw-r--r--dev-python/stevedore/stevedore-5.0.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/stevedore/Manifest b/dev-python/stevedore/Manifest
index ca4ba4b9fd51..204b3a02af15 100644
--- a/dev-python/stevedore/Manifest
+++ b/dev-python/stevedore/Manifest
@@ -1 +1,2 @@
DIST stevedore-4.1.1.tar.gz 514168 BLAKE2B b3b37bfae408adb1664562b99c9951ac035196babec8424068bcffa8226fed8da54044e6efe5b1b739b1caeb49bdaf1b65eca38ec6b4e200b837714d926e2dfb SHA512 9f75af586e4fff1bebb88351a242b171d6cce795d86cfffd021c47bafd9ced84a78a838a589d8828fa7bb0f183e767fe888b0780aeda9129895182bf4e0ff717
+DIST stevedore-5.0.0.tar.gz 513970 BLAKE2B e1135a281c88633daed4ec41a5bb66c3bf2ed2275a3502fbc90b6ba09ac55693e5c98a0af49d948adf141812e195dfdb6a293021405abdba962c05ff506a1879 SHA512 4041172deba14b8e33cb48d8b629810e66a52e1676a989417c1b896930e980e0057efbf8f9b6b9c4c82ffce02b132b8e6c5f7a5b02e49d7c7c242ab4a20bac02
diff --git a/dev-python/stevedore/stevedore-5.0.0.ebuild b/dev-python/stevedore/stevedore-5.0.0.ebuild
new file mode 100644
index 000000000000..aef754746b11
--- /dev/null
+++ b/dev-python/stevedore/stevedore-5.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="
+ https://opendev.org/openstack/stevedore/
+ https://github.com/openstack/stevedore/
+ https://pypi.org/project/stevedore/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx 'doc/source' \
+ '>=dev-python/openstackdocstheme-1.18.1' \
+ '>=dev-python/reno-2.5.0' \
+ '>=dev-python/sphinx-2.0.0'
+
+python_prepare_all() {
+ # Delete spurious data in requirements.txt
+ sed -e '/^pbr/d' -i requirements.txt || die
+
+ # Also known problem, inside venv
+ sed -i -e 's:test_disable_caching_file:_&:' \
+ stevedore/tests/test_cache.py || die
+
+ distutils-r1_python_prepare_all
+}