summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-14 15:12:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-14 15:12:48 +0200
commitf4e69eb734f36198a36e3432476f28711b0de678 (patch)
tree7a41010cf449ec147c178ce5b99c85155413f668 /dev-python/spotipy
parentwww-client/firefox: update 112.0's patchset to include a wayland patch (diff)
downloadgentoo-f4e69eb734f36198a36e3432476f28711b0de678.tar.gz
gentoo-f4e69eb734f36198a36e3432476f28711b0de678.tar.bz2
gentoo-f4e69eb734f36198a36e3432476f28711b0de678.zip
dev-python/spotipy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/spotipy')
-rw-r--r--dev-python/spotipy/Manifest1
-rw-r--r--dev-python/spotipy/spotipy-2.22.1.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index 7f08287826ac..9f7c8f6e6543 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1,2 +1 @@
-DIST spotipy-2.22.1.gh.tar.gz 111228 BLAKE2B df75cce406d59c9de3e4c836309262d61f7f1249761d3172be13033512944e69a56ca67f16b55e4736f760b74d3ebd8f384225ce9309a5fc1bd8c93be4099069 SHA512 d8c5871dd606e3335656fb55fa042d8c91c72a4c7d62a584bd407a7546184996694c67d499f908fc7049e406c548269286de6cba17064f0385adba3661b34c3b
DIST spotipy-2.23.0.gh.tar.gz 112399 BLAKE2B 5510ce35624c561df61fffee78f211dfa91ff8d5b3dc15d37c96a51bf830e67aac9c6a0787c71715bee17a3ba91b84766c1ecec37d5775f2182617f2b74a2cb3 SHA512 52955fa3365d5153f19f60874ce8e96910ac8db783499e0e2ef2ab31127277844e24a045115dc522dd7b7535f7907de56da87e02a63b94ee7506b75c1e108e9b
diff --git a/dev-python/spotipy/spotipy-2.22.1.ebuild b/dev-python/spotipy/spotipy-2.22.1.ebuild
deleted file mode 100644
index 6a9d5ec4fcdc..000000000000
--- a/dev-python/spotipy/spotipy-2.22.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A lightweight Python library for the Spotify Web API"
-HOMEPAGE="
- https://spotipy.readthedocs.io/
- https://github.com/spotipy-dev/spotipy/
- https://pypi.org/project/spotipy/
-"
-SRC_URI="
- https://github.com/spotipy-dev/spotipy/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-KEYWORDS="amd64 ~x86"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- dev-python/redis[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Internet
- tests/unit/test_oauth.py::TestSpotifyClientCredentials::test_spotify_client_credentials_get_access_token
-)
-
-python_install_all() {
- distutils-r1_python_install_all
-
- use examples && dodoc -r examples
-}