summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-24 07:23:45 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-24 08:04:11 +0100
commit1dd75bd44306f2ab665d88c49705474a464643d0 (patch)
tree8b1b7aa25775c3840c7ef958e6de8207ad69e38a /dev-python/spotipy
parentdev-python/awxkit: Bump to 21.11.0 (diff)
downloadgentoo-1dd75bd44306f2ab665d88c49705474a464643d0.tar.gz
gentoo-1dd75bd44306f2ab665d88c49705474a464643d0.tar.bz2
gentoo-1dd75bd44306f2ab665d88c49705474a464643d0.zip
dev-python/spotipy: Bump to 2.22.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/spotipy')
-rw-r--r--dev-python/spotipy/Manifest1
-rw-r--r--dev-python/spotipy/metadata.xml4
-rw-r--r--dev-python/spotipy/spotipy-2.22.1.ebuild51
3 files changed, 54 insertions, 2 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index 8cb5888e5230..3f8b5c41142f 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1,2 +1,3 @@
DIST spotipy-2.21.0.tar.gz 105500 BLAKE2B fa49c31da93efdac23fd5cbaa31b513f48e3a90c56dee8708bf695a20c1f6040c68a22a04d6589b3a890f503d54e7c0fb017f2911ae28abe54a9e7f5bff3b540 SHA512 8783261e43962b3e98cb9b680f908d38feecf784ff404352ba16d6bb3d2e4bf1d2308b60f1437c56402e1c2a993a5bba876103f968bb8bdd81be1aef1fe6d058
DIST spotipy-2.22.0.gh.tar.gz 109714 BLAKE2B 178a05252bc875630cee97628d228d9bd7d929d54fcb7ee30e92b685996fc9074063eae25b0b71089c3b51fcb29611c101acf0f606dc14a508f37e46c5522041 SHA512 272f05b1cb92dbd9842dcac58a5ca322fae703eea58488b968812c12b6c26fb748aabbf5fde7100e9662191231fe12f5353b9ba12f02bd2e4982e0aff1c732f6
+DIST spotipy-2.22.1.gh.tar.gz 111228 BLAKE2B df75cce406d59c9de3e4c836309262d61f7f1249761d3172be13033512944e69a56ca67f16b55e4736f760b74d3ebd8f384225ce9309a5fc1bd8c93be4099069 SHA512 d8c5871dd606e3335656fb55fa042d8c91c72a4c7d62a584bd407a7546184996694c67d499f908fc7049e406c548269286de6cba17064f0385adba3661b34c3b
diff --git a/dev-python/spotipy/metadata.xml b/dev-python/spotipy/metadata.xml
index 7e88424460d2..85e87c129849 100644
--- a/dev-python/spotipy/metadata.xml
+++ b/dev-python/spotipy/metadata.xml
@@ -7,8 +7,8 @@
<name>Maciej Barć</name>
</maintainer>
<upstream>
- <bugs-to>https://github.com/plamere/spotipy/issues/</bugs-to>
- <remote-id type="github">plamere/spotipy</remote-id>
+ <bugs-to>https://github.com/spotipy-dev/spotipy/issues/</bugs-to>
+ <remote-id type="github">spotipy-dev/spotipy</remote-id>
<remote-id type="pypi">spotipy</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/spotipy/spotipy-2.22.1.ebuild b/dev-python/spotipy/spotipy-2.22.1.ebuild
new file mode 100644
index 000000000000..cee91b6335a1
--- /dev/null
+++ b/dev-python/spotipy/spotipy-2.22.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight Python library for the Spotify Web API"
+HOMEPAGE="
+ https://spotipy.readthedocs.io/
+ https://github.com/spotipy-dev/spotipy/
+ https://pypi.org/project/spotipy/
+"
+SRC_URI="
+ https://github.com/spotipy-dev/spotipy/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/unit/test_oauth.py::TestSpotifyClientCredentials::test_spotify_client_credentials_get_access_token
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples
+}