summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-01 22:25:12 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-02 04:06:23 +0000
commit697e5fd9949491847a4a00c5008de3fbcb728f19 (patch)
treecf636706e8eb21307d7b6d9dd0c8fa57557f50f6 /dev-python/sphinxcontrib-cheeseshop
parentdev-python/sphinxcontrib-blockdiag: add namespace dependency and fix bug #623852 (diff)
downloadgentoo-697e5fd9949491847a4a00c5008de3fbcb728f19.tar.gz
gentoo-697e5fd9949491847a4a00c5008de3fbcb728f19.tar.bz2
gentoo-697e5fd9949491847a4a00c5008de3fbcb728f19.zip
dev-python/sphinxcontrib-cheeseshop: fix for bug #623852 and add namespace
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/sphinxcontrib-cheeseshop')
-rw-r--r--dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r2.ebuild b/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r2.ebuild
new file mode 100644
index 000000000000..0dad495679ab
--- /dev/null
+++ b/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension cheeseshop"
+HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/sphinx-1.0[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed \
+ -e '5s/file/open/' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}