summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-06 08:57:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-06 09:22:41 +0200
commitf9074b41c4330f2bc803d2a40392fe2bec1d6f2d (patch)
tree7e5a42c63de1a16bf920747ae6862978b64a73a5 /dev-python/sphinx_rtd_theme
parentdev-lang/python: Bump to 3.10.0a7 (diff)
downloadgentoo-f9074b41c4330f2bc803d2a40392fe2bec1d6f2d.tar.gz
gentoo-f9074b41c4330f2bc803d2a40392fe2bec1d6f2d.tar.bz2
gentoo-f9074b41c4330f2bc803d2a40392fe2bec1d6f2d.zip
dev-python/sphinx_rtd_theme: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx_rtd_theme')
-rw-r--r--dev-python/sphinx_rtd_theme/Manifest1
-rw-r--r--dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sphinx_rtd_theme/Manifest b/dev-python/sphinx_rtd_theme/Manifest
index e151455e7040..774ac096f560 100644
--- a/dev-python/sphinx_rtd_theme/Manifest
+++ b/dev-python/sphinx_rtd_theme/Manifest
@@ -1 +1,2 @@
DIST sphinx_rtd_theme-0.5.1.tar.gz 2774928 BLAKE2B 1ff9c2e1b7ef7740de4969b6b4862d9ac499d515163a32ca2b5438c84910d610c80f5e8c3d03e3016ffa8c58003abecb67bd036ded065dfb65318e2f1d7e69d9 SHA512 20a04408fdf3f5698fecb2a0a430eba6f484770c8e01026c0d444d25ffcbd798edb82aa4b489df10b63d9fcc5eac204e9e3ccdaaf7eac7eb0baee2a5d7960c30
+DIST sphinx_rtd_theme-0.5.2.tar.gz 7606638 BLAKE2B c104121b36c89f4d2b7c2fc12433ffd1a7cba9b9d532358dafd53061b2ca9ead4bb93b7b596394c244a9da51c0b9299f2fe0ec8d4ca102015b6c7dfb92081813 SHA512 dd46bfeb05b433970d8130c06cad6dfa9dbc4e9db2d9a8190b80232d75b4d0a86590c17d64b9b1dcd2cb1d042033f4d2c2ce2e5cac0239c6b86899628b94b274
diff --git a/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.2.ebuild b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.2.ebuild
new file mode 100644
index 000000000000..e3330c4a7221
--- /dev/null
+++ b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ReadTheDocs.org theme for Sphinx"
+HOMEPAGE="https://github.com/readthedocs/sphinx_rtd_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+PDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+RDEPEND="<dev-python/docutils-0.17[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/readthedocs-sphinx-ext[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # CI=1 disables rebuilding webpack that requires npm use
+ # yes, that surely makes sense
+ export CI=1
+}