summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-09 07:09:56 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-09 08:30:50 +0200
commitd13684de97c21f9c1016d11978ff60bae72bcf8a (patch)
tree81de25eae3a142374254c8e5bc9c0a79c3d68833 /dev-python/sphinx-tabs
parentdev-python/time-machine: Bump to 2.16.0 (diff)
downloadgentoo-d13684de97c21f9c1016d11978ff60bae72bcf8a.tar.gz
gentoo-d13684de97c21f9c1016d11978ff60bae72bcf8a.tar.bz2
gentoo-d13684de97c21f9c1016d11978ff60bae72bcf8a.zip
dev-python/sphinx-tabs: Bump to 3.4.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-tabs')
-rw-r--r--dev-python/sphinx-tabs/Manifest1
-rw-r--r--dev-python/sphinx-tabs/sphinx-tabs-3.4.7.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinx-tabs/Manifest b/dev-python/sphinx-tabs/Manifest
index 61083abe9c28..7850c5ffb361 100644
--- a/dev-python/sphinx-tabs/Manifest
+++ b/dev-python/sphinx-tabs/Manifest
@@ -1 +1,2 @@
DIST sphinx-tabs-3.4.5.gh.tar.gz 524298 BLAKE2B 64f7a9e470e35e4e0c2e80c5207fcaa920adbf198c3bcd501d316282bf1c0f052effc6e885fcbd1385395f4ac9e5721c0904b673e8975ef8aa3bd68ebe9ae415 SHA512 530b6929733385a42ef3f1828f0d7aa4b442eb9ced0befe9adeaf4b559a62cb2a1865443e554493b8fa2c6a9d2dd5dfdbf55078ee63d21f1c22afd8275a690b9
+DIST sphinx-tabs-3.4.7.gh.tar.gz 523984 BLAKE2B e9f99c08cdc62d98b4a02af9a4d4b0ba5169b0ba42f0fe4468ede968473d1f3c92d86f95216a49ae932334de6485df11b0966624c722ad705d570031ab4ff4a5 SHA512 6310838496b365b837966149a97e1b3b227d795fab8de5f277daffd1c65eab9fdaacd58944491f339f99372dde73d776b596f94283aaab8d87c5065d02b443e7
diff --git a/dev-python/sphinx-tabs/sphinx-tabs-3.4.7.ebuild b/dev-python/sphinx-tabs/sphinx-tabs-3.4.7.ebuild
new file mode 100644
index 000000000000..ef2c643db734
--- /dev/null
+++ b/dev-python/sphinx-tabs/sphinx-tabs-3.4.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tabbed views for Sphinx"
+HOMEPAGE="
+ https://github.com/executablebooks/sphinx-tabs/
+ https://pypi.org/project/sphinx-tabs/
+"
+SRC_URI="
+ https://github.com/executablebooks/sphinx-tabs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+EPYTEST_DESELECT=(
+ # Unpackaged rinohtype
+ tests/test_build.py::test_rinohtype_pdf
+)