summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-22 04:28:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-22 04:32:15 +0100
commit44d1df63521ccb05c8c71970400a38034f7b5400 (patch)
treed0667996220874f8146cc61358e5b87a5e69ced9 /dev-python/sphinx-tabs
parentdev-python/nest-asyncio: Bump to 1.6.0 (diff)
downloadgentoo-44d1df63521ccb05c8c71970400a38034f7b5400.tar.gz
gentoo-44d1df63521ccb05c8c71970400a38034f7b5400.tar.bz2
gentoo-44d1df63521ccb05c8c71970400a38034f7b5400.zip
dev-python/sphinx-tabs: Bump to 3.4.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-tabs')
-rw-r--r--dev-python/sphinx-tabs/Manifest1
-rw-r--r--dev-python/sphinx-tabs/sphinx-tabs-3.4.5.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinx-tabs/Manifest b/dev-python/sphinx-tabs/Manifest
index 050142c2b9f0..00f150620579 100644
--- a/dev-python/sphinx-tabs/Manifest
+++ b/dev-python/sphinx-tabs/Manifest
@@ -1 +1,2 @@
DIST sphinx-tabs-3.4.4.gh.tar.gz 524297 BLAKE2B 5361006ca99be157f01a7efd6ea50bbd87c1672caf0badbbde11ef832dddfd40232723fc5900a37fdb18112c5e4ddd9717829e96fd6e3afad8205c11c209d439 SHA512 365c472e88016e5c2d83a509d617ff13fc2c8c0a35fa9626244de9af2a242c2bbc4941241b3d1d863d261b15967a5694a0edb6c1d5614dce9d72531ea5138e03
+DIST sphinx-tabs-3.4.5.gh.tar.gz 524298 BLAKE2B 64f7a9e470e35e4e0c2e80c5207fcaa920adbf198c3bcd501d316282bf1c0f052effc6e885fcbd1385395f4ac9e5721c0904b673e8975ef8aa3bd68ebe9ae415 SHA512 530b6929733385a42ef3f1828f0d7aa4b442eb9ced0befe9adeaf4b559a62cb2a1865443e554493b8fa2c6a9d2dd5dfdbf55078ee63d21f1c22afd8275a690b9
diff --git a/dev-python/sphinx-tabs/sphinx-tabs-3.4.5.ebuild b/dev-python/sphinx-tabs/sphinx-tabs-3.4.5.ebuild
new file mode 100644
index 000000000000..821eca256dbe
--- /dev/null
+++ b/dev-python/sphinx-tabs/sphinx-tabs-3.4.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tabbed views for Sphinx"
+HOMEPAGE="
+ https://github.com/executablebooks/sphinx-tabs/
+ https://pypi.org/project/sphinx-tabs/
+"
+SRC_URI="
+ https://github.com/executablebooks/sphinx-tabs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+EPYTEST_DESELECT=(
+ # Unpackaged rinohtype
+ tests/test_build.py::test_rinohtype_pdf
+)