summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2016-11-28 18:48:35 -0600
committerDenis Dupeyron <calchan@gentoo.org>2016-11-28 18:48:35 -0600
commite049b641dc81ae127606a4e7a49df459b060aaed (patch)
tree4e7c8a1ac74ab1b6c4e72a41b70a905b673db65d /dev-python/spark-parser
parentsys-cluster/nova: switch to cdrtools for bug 591784 (diff)
downloadgentoo-e049b641dc81ae127606a4e7a49df459b060aaed.tar.gz
gentoo-e049b641dc81ae127606a4e7a49df459b060aaed.tar.bz2
gentoo-e049b641dc81ae127606a4e7a49df459b060aaed.zip
dev-python/spark-parser: bump to 1.5.1 at dolsen's request
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/spark-parser')
-rw-r--r--dev-python/spark-parser/Manifest1
-rw-r--r--dev-python/spark-parser/spark-parser-1.5.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/spark-parser/Manifest b/dev-python/spark-parser/Manifest
index a7ab257de95b..ffc4005ecc66 100644
--- a/dev-python/spark-parser/Manifest
+++ b/dev-python/spark-parser/Manifest
@@ -1 +1,2 @@
DIST spark_parser-1.4.0.tar.gz 99006 SHA256 282fe0d19de48d5fda6148032e47c822e2f088a5ff050cb7544f2bc2e701ede4 SHA512 1236fcfabcf4b829f70db240fd76baabc79873c03e96d9fdd92e6c23661e144c1b32d317a51f96f683bc6f96763cac0989709e344e53410ae949d30305dfadef WHIRLPOOL 1e8bfc67950e973fc80313d53f3df0da90c083da4482de1e2fac0fb2eb8698140aa1fda93cb0018b127b42a11cd3e8f68b2bfed77f43df9ed392ba668363eba5
+DIST spark_parser-1.5.1.tar.gz 111933 SHA256 b6753103f3744deefde7f841c275e4d15d813059a5b575ca7df28fa45480f83a SHA512 d46e4bf27b867e7e20e5d9d226d606428cc2173afdca27d5f8d26db2515a7ecb89b7a27cb091ff3d7d7c9cde748cc0e027b1f9212a2fc7b75144e156d16c8916 WHIRLPOOL 878054b393b6c2d74e46dcf2ba88f8966c45fedacc08557e31900718bd995cbc51a34b822657c8ee81af11b712cedda7358dfb77261dd5cb9a2150144d52b989
diff --git a/dev-python/spark-parser/spark-parser-1.5.1.ebuild b/dev-python/spark-parser/spark-parser-1.5.1.ebuild
new file mode 100644
index 000000000000..3c0cd9af4894
--- /dev/null
+++ b/dev-python/spark-parser/spark-parser-1.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+
+inherit distutils-r1
+
+MY_PN="spark_parser"
+
+DESCRIPTION="An Early-Algorithm Context-free grammar Parser"
+HOMEPAGE="https://github.com/rocky/python-spark/ https://pypi.python.org/pypi/spark_parser"
+SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ # Remove an unconditional test only dep
+ sed \
+ -e "s/setup_requires/# setup_requires/" \
+ -i setup.py
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ emake check
+}