summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-01-09 16:09:04 -0500
committerTim Harder <radhermit@gentoo.org>2016-01-09 16:22:32 -0500
commit0e10f27d5382566aa9a6b34b4f28344ff9f006d2 (patch)
tree3f8ca7573eb6d616f3d771e4587738a189e06ad6 /dev-python/snakeoil
parentapp-portage/grs: stable for amd64 (diff)
downloadgentoo-0e10f27d5382566aa9a6b34b4f28344ff9f006d2.tar.gz
gentoo-0e10f27d5382566aa9a6b34b4f28344ff9f006d2.tar.bz2
gentoo-0e10f27d5382566aa9a6b34b4f28344ff9f006d2.zip
dev-python/snakeoil: version bump to 0.6.6
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/Manifest1
-rw-r--r--dev-python/snakeoil/snakeoil-0.6.6.ebuild33
-rw-r--r--dev-python/snakeoil/snakeoil-9999.ebuild4
3 files changed, 36 insertions, 2 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index 986b5241d563..ee828228be16 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1,2 +1,3 @@
DIST snakeoil-0.6.4.tar.gz 192291 SHA256 8636918381db16bf910afcb30a5e8722038afda32fbf41a977fabea75775131e SHA512 c2290801426de1fd6fe3e668edfc36e05cf50a6990f336eb604eece27f56716b5cff672ca7642906636fa1a8afa82f37867e898680f54b154c37cf51ef72eb9e WHIRLPOOL 08c778296f0881c1884eb0c23fc2e4e81b28f406971d84d71641ac4b4b864e8f472c06fad2937d279565b627ef983f89dbe6e6e1a5dbe7b4263ac00b5d76aea5
DIST snakeoil-0.6.5.tar.gz 195182 SHA256 af02d9e28097083683d29267ed8b1a748d9a5f4a822fe733176b92fc8793cb33 SHA512 44895dd4ea72d1d43afddb7b1b13009c21b1c26fab30d7b2fa29115ca62202b3a1a311f22f9d925a78650d1c1012313e98783ebc5c0cb37b0e70aae0f1e14371 WHIRLPOOL 8886591e7e87de91f413cdab384c938d2a1ebbb0569601559fb2fd62329eb19936743211cbc0988af781f95e5c40dea2ac4b141f194fe72e74d89fe43d83cf59
+DIST snakeoil-0.6.6.tar.gz 198899 SHA256 16e2d4f257ecea340134f0e1e97c4d363f6e3c8f87bf5d8ba49d48955406f9f2 SHA512 d6502d345dc26f2048855fe6e468918c5f0a7d66165152cb5bf38cb4b4ebdb45a5eab346a19a6cad04f0fbf905200b90d660a36b52df000164b117fe2d536f35 WHIRLPOOL 81ecac1317f00be47ba482564dd5c11f4fdbc69df70badf2c8e555c34cd79b55e75c1e18e17bbc427b23b80e41f43f60e6fd29679c88361b5ac86b21afdc60d1
diff --git a/dev-python/snakeoil/snakeoil-0.6.6.ebuild b/dev-python/snakeoil/snakeoil-0.6.6.ebuild
new file mode 100644
index 000000000000..7b7ed4c5cdd0
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.6.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="Miscellaneous python utility code"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_configure_all() {
+ # disable snakeoil 2to3 caching
+ unset PY2TO3_CACHEDIR
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/snakeoil/snakeoil-9999.ebuild b/dev-python/snakeoil/snakeoil-9999.ebuild
index 2a56c967574c..7b7ed4c5cdd0 100644
--- a/dev-python/snakeoil/snakeoil-9999.ebuild
+++ b/dev-python/snakeoil/snakeoil-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1