summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/smmap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/smmap')
-rw-r--r--dev-python/smmap/Manifest2
-rw-r--r--dev-python/smmap/metadata.xml9
-rw-r--r--dev-python/smmap/smmap-0.8.3.ebuild33
-rw-r--r--dev-python/smmap/smmap-0.9.0.ebuild32
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/smmap/Manifest b/dev-python/smmap/Manifest
new file mode 100644
index 000000000000..5bb42a07b6f1
--- /dev/null
+++ b/dev-python/smmap/Manifest
@@ -0,0 +1,2 @@
+DIST smmap-0.8.3.tar.gz 21787 SHA256 9b336afff785e8934afe22a520d2c88574ae716aaf3ce8290581af943ba6fdde SHA512 dff14f25487d83ac348d3f4c9556f6e972c4e1166ac70cc9ca0b70a7e210750a67f4ed85203bebdacc6e8f912cabf55135a0da26c7ae2b017caf2f1682b22608 WHIRLPOOL 3eb3979877ff43c1c518b9313228f52627621ac187c416b61e43f1be1dbb1efc5661ba62a4d3088ed8143a780404296d26b729dab9ff6e9432f78069dfb95b1a
+DIST smmap-0.9.0.tar.gz 22082 SHA256 0e2b62b497bd5f0afebc002eda4d90df9d209c30ef257e8673c90a6b5c119d62 SHA512 704e1c67b1f3e1303578cc26d4af8296a11b5f5013e8e8d933d3096e588911b801ddfb162d0e35a49c00256032824386d77e4f38d58704cd57baf21586b40e03 WHIRLPOOL 9fb316ee42e7d0e9ee46cda05659d3abbe1c0b17917d675c774b1b34e35e16497afef97b0575478bf7d795c6242d77e1456630b3d7739ef979ca8d08ba042498
diff --git a/dev-python/smmap/metadata.xml b/dev-python/smmap/metadata.xml
new file mode 100644
index 000000000000..e4c82cb2ad4f
--- /dev/null
+++ b/dev-python/smmap/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">smmap</remote-id>
+ <remote-id type="github">Byron/smmap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/smmap/smmap-0.8.3.ebuild b/dev-python/smmap/smmap-0.8.3.ebuild
new file mode 100644
index 000000000000..661af0d7b2b2
--- /dev/null
+++ b/dev-python/smmap/smmap-0.8.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure git implementation of a sliding window memory map manager"
+HOMEPAGE="
+ http://pypi.python.org/pypi/smmap
+ https://github.com/Byron/smmap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nosexcover[${PYTHON_USEDEP}]
+ )
+ "
+RDEPEND=""
+
+python_test() {
+ nosetests || die
+}
diff --git a/dev-python/smmap/smmap-0.9.0.ebuild b/dev-python/smmap/smmap-0.9.0.ebuild
new file mode 100644
index 000000000000..4a804cfb7ad4
--- /dev/null
+++ b/dev-python/smmap/smmap-0.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure git implementation of a sliding window memory map manager"
+HOMEPAGE="
+ http://pypi.python.org/pypi/smmap
+ https://github.com/Byron/smmap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nosexcover[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}