summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/simpletal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/simpletal')
-rw-r--r--dev-python/simpletal/Manifest3
-rw-r--r--dev-python/simpletal/metadata.xml5
-rw-r--r--dev-python/simpletal/simpletal-4.2-r1.ebuild41
-rw-r--r--dev-python/simpletal/simpletal-5.1-r1.ebuild41
-rw-r--r--dev-python/simpletal/simpletal-5.2.ebuild41
5 files changed, 131 insertions, 0 deletions
diff --git a/dev-python/simpletal/Manifest b/dev-python/simpletal/Manifest
new file mode 100644
index 000000000000..201509527bb6
--- /dev/null
+++ b/dev-python/simpletal/Manifest
@@ -0,0 +1,3 @@
+DIST SimpleTAL-4.2.tar.gz 96011 SHA256 3f2983773382491c981e8f621094be4ea4e202336c96f81f9a1f7305e4b2eb08 SHA512 ce816a9c7c66ffa96da0968cea60d838b7e9ed5608a0eae05c40fbbacddec2ca369944f820237d9c3756cd14552d7957c86f8f3e8067cb944ac86529232aa0c8 WHIRLPOOL 6dd675f113d37209a4d10945c0f7116e3d4b45f31bbdfe4488e17150d3969a27e1cb348c3d0136878bae456de646fa8ab086c78d67b8a49046e0b7261261a484
+DIST SimpleTAL-5.1.tar.gz 90604 SHA256 00118ccf7eb74cb3e536a891a1858ad31a2416f63a85cf61fd538bde4c760057 SHA512 51fc5bcfdb4a5ac06b06d7aca20d13cb964a625d0167cc723e8b7352cf154bcde9f14aff96eaa42a5b299c8439336cd35d8fc8f927ae1352be7e7ca5f12aba52 WHIRLPOOL 25e40138a4e53a6f8a6aaa6d607e082ac8ba428ff8b99336d91c5d10e3a6ae8d203e6a49756c96d5357b8605ad4a6eafc3501403a62dce63127eb3ff8ff485bd
+DIST SimpleTAL-5.2.tar.gz 96986 SHA256 ddff80acdebfffc9cb7de2e20761936ea06fcc7cf362678d4b66bd7bbce9e8e2 SHA512 16b46886af50f697e706c6b3f0400707299cfe40a81773fbd094de2f52ca8a87438f3ae7477462d0523570b3e3248d2ad4bb2affd3a7088fc45b1201ed228fbe WHIRLPOOL ea412134f341b572936f0543a944d1d9cae4394be801cf879fdf0859379eb0bc17eda781a62f165e54ce90c511ae7d5dec180f9c718e3ec88fb65fd113c9e284
diff --git a/dev-python/simpletal/metadata.xml b/dev-python/simpletal/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/simpletal/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/simpletal/simpletal-4.2-r1.ebuild b/dev-python/simpletal/simpletal-4.2-r1.ebuild
new file mode 100644
index 000000000000..9c0a71a2b695
--- /dev/null
+++ b/dev-python/simpletal/simpletal-4.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="SimpleTAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Stand alone Python implementation of the Zope TAL, TALES and METAL specs for HTML/XML templates"
+HOMEPAGE="http://www.owlfish.com/software/simpleTAL/ http://pypi.python.org/pypi/SimpleTAL"
+SRC_URI="http://www.owlfish.com/software/simpleTAL/downloads/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyxml[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "s/^TEMP_DIR=.*/TEMP_DIR=os.curdir/" \
+ -i tests/TALUtilsTests/TemplateCacheTestCases.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" runtests.py || die "tests failed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/simpletal/simpletal-5.1-r1.ebuild b/dev-python/simpletal/simpletal-5.1-r1.ebuild
new file mode 100644
index 000000000000..b7e40a3356ce
--- /dev/null
+++ b/dev-python/simpletal/simpletal-5.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 )
+
+inherit distutils-r1
+
+MY_PN="SimpleTAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Stand alone Python implementation of the Zope TAL, TALES and METAL specs for HTML/XML templates"
+HOMEPAGE="http://www.owlfish.com/software/simpleTAL/ http://pypi.python.org/pypi/SimpleTAL"
+SRC_URI="http://www.owlfish.com/software/simpleTAL/downloads/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "s/^TEMP_DIR=.*/TEMP_DIR=os.curdir/" \
+ -i tests/TALUtilsTests/TemplateCacheTestCases.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" runtests.py || die "tests failed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/simpletal/simpletal-5.2.ebuild b/dev-python/simpletal/simpletal-5.2.ebuild
new file mode 100644
index 000000000000..b7e40a3356ce
--- /dev/null
+++ b/dev-python/simpletal/simpletal-5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 )
+
+inherit distutils-r1
+
+MY_PN="SimpleTAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Stand alone Python implementation of the Zope TAL, TALES and METAL specs for HTML/XML templates"
+HOMEPAGE="http://www.owlfish.com/software/simpleTAL/ http://pypi.python.org/pypi/SimpleTAL"
+SRC_URI="http://www.owlfish.com/software/simpleTAL/downloads/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "s/^TEMP_DIR=.*/TEMP_DIR=os.curdir/" \
+ -i tests/TALUtilsTests/TemplateCacheTestCases.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" runtests.py || die "tests failed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}