summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2018-05-07 10:33:04 -0400
committerJustin Bronder <jsbronder@gentoo.org>2018-05-07 10:33:21 -0400
commit01196e28b4a92fb1b5d7e2ba144d1314953f1cf3 (patch)
tree2c96b5a4956c9f7f0023b0d7ea63886e455615d3 /dev-python/sabyenc/sabyenc-3.3.5.ebuild
parentapp-i18n/ibus: tidy (diff)
downloadgentoo-01196e28b4a92fb1b5d7e2ba144d1314953f1cf3.tar.gz
gentoo-01196e28b4a92fb1b5d7e2ba144d1314953f1cf3.tar.bz2
gentoo-01196e28b4a92fb1b5d7e2ba144d1314953f1cf3.zip
dev-python/sabyenc: bump 3.3.5
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/sabyenc/sabyenc-3.3.5.ebuild')
-rw-r--r--dev-python/sabyenc/sabyenc-3.3.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/sabyenc/sabyenc-3.3.5.ebuild b/dev-python/sabyenc/sabyenc-3.3.5.ebuild
new file mode 100644
index 000000000000..7c8c926ed06c
--- /dev/null
+++ b/dev-python/sabyenc/sabyenc-3.3.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="https://github.com/sabnzbd/sabyenc/"
+SRC_URI="https://github.com/sabnzbd/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( CHANGES.md README.md doc/yenc-draft.1.3.txt )
+
+python_test() {
+ pytest -v || die "Test failed."
+}