summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-23 04:16:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-23 04:37:03 +0100
commit79dd9a601ca64552194e71444a306938dd27ad2e (patch)
treeed597b532c1fa87c34fd03f4e2921687fe0aa63a /dev-python/rustworkx
parentdev-python/stevedore: Bump to 5.2.0 (diff)
downloadgentoo-79dd9a601ca64552194e71444a306938dd27ad2e.tar.gz
gentoo-79dd9a601ca64552194e71444a306938dd27ad2e.tar.bz2
gentoo-79dd9a601ca64552194e71444a306938dd27ad2e.zip
dev-python/rustworkx: Bump to 0.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rustworkx')
-rw-r--r--dev-python/rustworkx/Manifest1
-rw-r--r--dev-python/rustworkx/rustworkx-0.14.1.ebuild153
2 files changed, 154 insertions, 0 deletions
diff --git a/dev-python/rustworkx/Manifest b/dev-python/rustworkx/Manifest
index b893554a8c43..3a9fcbf06d2c 100644
--- a/dev-python/rustworkx/Manifest
+++ b/dev-python/rustworkx/Manifest
@@ -103,6 +103,7 @@ DIST redox_syscall-0.4.1.crate 24858 BLAKE2B c3301137a0b84e03b09d28dfa377ab3bea7
DIST rustc-hash-1.1.0.crate 9331 BLAKE2B 16ac56622897f47a06b661fb59a196b08d48e782ab87549c8bd5c6fe92f374c9bfd44dcb36588512bd9b6125c2fd79a12d648aaa308fd9694bcca3a7c1b49ac9 SHA512 84e673ea9b046f7b989d47f2c4505557fbd5de991e6fc9f56a03605d40e0b4ba5427cd566954890153cc033ccbec6c984306634571935bfe0d4cdfbe56f39544
DIST rustworkx-0.13.2.gh.tar.gz 599348 BLAKE2B 77067f1ac27fd578b9e9d0e485fd5f516a7799941ff51b83eb5fb6644de328c29567c7ac2a0bea4944be5ae412f130ca12f6fd42efa57272a3cc35955399d003 SHA512 c7a18627511c0e6131b6fe94f8a0e6ac3949a13acab925e6da937c0312dabac868bb7774b13ed1b875ce033a2e8a5cf58148e94b5223ca6fe7ca4c9c2310c2b3
DIST rustworkx-0.14.0.gh.tar.gz 557593 BLAKE2B aad2c95f5e3fee6939cbfc53b81197b5fd149925a3be683a09412c5f2d0b32da90ed06d5efb5f24b6f77138074fb4234d16296119890c9e15a8d3002c2112638 SHA512 d4f8bdebccb7fb6eb8e5f6caf85122e7f3d8d34b1a21ce9b894fdeaa338f5d1141fa7168b06b6a11b11499df0f83234d3d90bb3f12d60207a7a0cb0f29245cbf
+DIST rustworkx-0.14.1.gh.tar.gz 558055 BLAKE2B 03ebbd55762ef3f8834ed688782580a2ffb05dc34410c9970337d776bcc52afb2ee474860cbcd173d57c3736b8562a1848df558d304de872d4f0e98522c57d46 SHA512 22fd8c8dedeb0a60efe6b16c3e268fa6bc599b7ddf0104349cbb4ec0664548416427d22712456a19f7b97fbea2dd7aba6bdc3ce7e582a1f1d95225b6d567be06
DIST ryu-1.0.11.crate 47007 BLAKE2B d03e8df69c3b21c1b2e4ffa91ece794f141e9f9bce4e9ed1ebf394b1cb0f796147b86189885f0734df8f431b2d166d8f6ed6a261be398d6d088fd56046a85c2e SHA512 dd2642aab2d3017c31432436226d5350b894c8b88a09395eb7de6350964b3cc48451a829ce78b04a9e4e0480076fe1bddd0604f4e57700faa2d60cac6e361408
DIST ryu-1.0.16.crate 47351 BLAKE2B 13c72ec8aa608f6c53cf27c95d06b90839c5bec5e54b0441e9c4f779af3dece30d01a2276c717a733f92406a5a02b09c045b2b5f92714fe492d7263b6c6808e6 SHA512 89e3e18346ae6e4035787766f286a6eb62f5294e39ad902cc29e95c53781c4e5dd629f567f22ecc7e9fe9d1c273323da9b867aadc9cd8a066727c58330b51b10
DIST scopeguard-1.1.0.crate 11470 BLAKE2B f774eb90b7d3ffb2efba47518e9d1dead4017ab4b38a4bd74914daa84a5af4bf9eb63da0496e3924499d79cd0439c37447aeda4a21226f95645bddcd6becfabe SHA512 368fa5726df8f42b599993681579a9ffd0196480ee3cd0f9f671e8493f3bedd1e1779bdf2beb329e77e0005fa09b816e3385f309490c0f2781568db275d4d17d
diff --git a/dev-python/rustworkx/rustworkx-0.14.1.ebuild b/dev-python/rustworkx/rustworkx-0.14.1.ebuild
new file mode 100644
index 000000000000..7e40a54f5d64
--- /dev/null
+++ b/dev-python/rustworkx/rustworkx-0.14.1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+CRATES="
+ ahash@0.8.6
+ alga@0.9.3
+ allocator-api2@0.2.16
+ approx@0.3.2
+ autocfg@1.1.0
+ bitflags@1.3.2
+ cfg-if@1.0.0
+ crossbeam-deque@0.8.5
+ crossbeam-epoch@0.9.18
+ crossbeam-utils@0.8.19
+ either@1.9.0
+ equivalent@1.0.1
+ fixedbitset@0.4.2
+ getrandom@0.2.12
+ hashbrown@0.12.3
+ hashbrown@0.14.3
+ heck@0.4.1
+ hermit-abi@0.3.4
+ indexmap@1.9.3
+ indexmap@2.1.0
+ indoc@2.0.4
+ itertools@0.10.5
+ itertools@0.11.0
+ itoa@1.0.10
+ libc@0.2.152
+ libm@0.2.8
+ lock_api@0.4.11
+ matrixmultiply@0.3.8
+ memchr@2.7.1
+ memoffset@0.9.0
+ ndarray-stats@0.5.1
+ ndarray@0.15.6
+ noisy_float@0.2.0
+ num-bigint@0.4.4
+ num-complex@0.2.4
+ num-complex@0.4.4
+ num-integer@0.1.45
+ num-traits@0.2.17
+ num_cpus@1.16.0
+ numpy@0.20.0
+ once_cell@1.19.0
+ parking_lot@0.12.1
+ parking_lot_core@0.9.9
+ petgraph@0.6.4
+ ppv-lite86@0.2.17
+ priority-queue@1.3.2
+ proc-macro2@1.0.78
+ pyo3-build-config@0.20.2
+ pyo3-ffi@0.20.2
+ pyo3-macros-backend@0.20.2
+ pyo3-macros@0.20.2
+ pyo3@0.20.2
+ quick-xml@0.31.0
+ quote@1.0.35
+ rand@0.8.5
+ rand_chacha@0.3.1
+ rand_core@0.6.4
+ rand_pcg@0.3.1
+ rawpointer@0.2.1
+ rayon-cond@0.3.0
+ rayon-core@1.12.1
+ rayon@1.8.1
+ redox_syscall@0.4.1
+ rustc-hash@1.1.0
+ ryu@1.0.16
+ scopeguard@1.2.0
+ serde@1.0.195
+ serde_derive@1.0.195
+ serde_json@1.0.111
+ smallvec@1.13.1
+ sprs@0.11.1
+ syn@2.0.48
+ target-lexicon@0.12.13
+ unicode-ident@1.0.12
+ unindent@0.2.3
+ version_check@0.9.4
+ wasi@0.11.0+wasi-snapshot-preview1
+ windows-targets@0.48.5
+ windows_aarch64_gnullvm@0.48.5
+ windows_aarch64_msvc@0.48.5
+ windows_i686_gnu@0.48.5
+ windows_i686_msvc@0.48.5
+ windows_x86_64_gnu@0.48.5
+ windows_x86_64_gnullvm@0.48.5
+ windows_x86_64_msvc@0.48.5
+ zerocopy-derive@0.7.32
+ zerocopy@0.7.32
+"
+
+inherit cargo distutils-r1
+
+DESCRIPTION="A high performance Python graph library implemented in Rust"
+HOMEPAGE="
+ https://github.com/Qiskit/rustworkx/
+ https://pypi.org/project/rustworkx/
+"
+SRC_URI="
+ https://github.com/Qiskit/rustworkx/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+
+LICENSE="Apache-2.0"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 MIT
+ Unicode-DFS-2016
+ || ( LGPL-3 MPL-2.0 )
+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/numpy-1.16.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-rust[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ >=dev-python/networkx-2.5[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.5.0[${PYTHON_USEDEP}]
+ media-gfx/graphviz[gts]
+ )
+"
+
+# Libraries built with rust do not use CFLAGS and LDFLAGS.
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/rustworkx/rustworkx.*\\.so"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_DESELECT=(
+ # TODO: hangs
+ tests/retworkx_backwards_compat/visualization/test_mpl.py
+ tests/rustworkx_tests/visualization/test_mpl.py
+ )
+ rm -rf rustworkx || die
+ epytest
+}