summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-12 20:22:12 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-12 21:24:16 +0100
commita18004b25adadbc2967574559c482d37d2dac150 (patch)
tree93415630cf837a441bb78528cbe94688fdb7379e /dev-python/ruamel-yaml
parentdev-python/pandas: Bump to 1.4.1 (diff)
downloadgentoo-a18004b25adadbc2967574559c482d37d2dac150.tar.gz
gentoo-a18004b25adadbc2967574559c482d37d2dac150.tar.bz2
gentoo-a18004b25adadbc2967574559c482d37d2dac150.zip
dev-python/ruamel-yaml: Bump to 0.17.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/Manifest1
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.21.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index f96cee2d5296..d3546736a7f0 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -1 +1,2 @@
DIST ruamel.yaml-0.17.20.tar.xz 184628 BLAKE2B 0b50240717c10d6dd5aefed9e092fddf503f079066ed49d1f614928046544a67b9168c76a58ee5fbe782fe6e1296a6282416fa8567783f4543ef9c8c0ad340ca SHA512 8c2614ffecba1560e829cfc27f9b4effec589f9eba90792c470ba8f531fecd06ae6f12036ee5463f89021360fb4f35e9b78a16fc778507e88c5c6a8f6e293876
+DIST ruamel.yaml-0.17.21.tar.xz 184612 BLAKE2B cc7e2a336d3c77a9f2d7e5d7233ceb4d15fddca3a97ec0e54427469fd24c7c63fc70b258adbad92a816d99a1f9839d41eccb9f3224e7a23884914755fa424bc9 SHA512 87f4723bfc76b1b21168852aabe4b49921f175294ac05b4e3f292f2bcf23fe6595df3e066843d193f881b274be2a7b358bd04625afef913bb0e5811efe98b761
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.21.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.21.ebuild
new file mode 100644
index 000000000000..a3068aac1127
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.21.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/p/ruamel-yaml/"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/namespace-ruamel[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+# Old PyYAML tests from lib/ require special set-up and are invoked indirectly
+# via test_z_olddata, tell pytest itself to leave the subdir alone.
+python_test() {
+ [[ ${EPYTHON} == pypy3 ]] && local EPYTEST_DESELECT=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ _test/lib/
+ )
+ epytest
+}
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}