summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-06-22 10:15:51 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-06-24 09:28:06 +0100
commit98c44f77d804aa9d0a88051e3ecabb8d47c6ec33 (patch)
tree49165174166cfc33efc8bfbcabb95bfecf1f5d8d /dev-python/ruamel-std-pathlib
parentdev-python/ruamel-yaml: drop PYTHON_DEPS from RDEPEND (diff)
downloadgentoo-98c44f77d804aa9d0a88051e3ecabb8d47c6ec33.tar.gz
gentoo-98c44f77d804aa9d0a88051e3ecabb8d47c6ec33.tar.bz2
gentoo-98c44f77d804aa9d0a88051e3ecabb8d47c6ec33.zip
dev-python/ruamel-std-pathlib: add new version 0.6.4
This release fixes Python 3.7 support. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-std-pathlib')
-rw-r--r--dev-python/ruamel-std-pathlib/Manifest1
-rw-r--r--dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/ruamel-std-pathlib/Manifest b/dev-python/ruamel-std-pathlib/Manifest
index 4755eec233b9..bba6a7265cd3 100644
--- a/dev-python/ruamel-std-pathlib/Manifest
+++ b/dev-python/ruamel-std-pathlib/Manifest
@@ -1 +1,2 @@
DIST ruamel-std-pathlib-0.6.3.tar.gz 19520 BLAKE2B b403338cec80b38104f012c2b2626d473f12d557c2300d606462f2eb009bac72cec65b2f4e5a88192832a99dfc28573ea9ba8e7b73078ad8bac77136dd929040 SHA512 1210d8f7ae77c6358fc857c3ee447b2eb9802eaa31a210804acd74ec23dfd6ac9dec90dd7b21c79dcb4845dff4ad3614dd615c4798d3d7a39cc3a877cb9b63b0
+DIST ruamel-std-pathlib-0.6.4.tar.gz 20719 BLAKE2B 7189b10e61c941d2bba9bcbff3b61f2ad52849d78160b181721fef3bf3a9170aac823631e1743de98d1c132e38092a38781c9c8d0d213e4b94cc1e6051edb2b7 SHA512 591aec63c14c269d6b0838ae4867d58bd0642cf84cff841eda53a4d60f076ba68fdcb54d7e2932b248ee61feb773bf28b6309947886d350af34ed9f580c9d939
diff --git a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.4.ebuild b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.4.ebuild
new file mode 100644
index 000000000000..7e66ea38deed
--- /dev/null
+++ b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN="${PN//-/.}"
+
+DESCRIPTION="Ruamel enhancements to pathlib and pathlib2"
+HOMEPAGE="https://pypi.org/project/ruamel.std.pathlib/ https://bitbucket.org/ruamel/std.pathlib"
+SRC_URI="https://bitbucket.org/${MY_PN/.//}/get/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v _test/test_*.py || die
+}
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}