summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwxy <wxy@unreadableco.de>2023-03-28 01:24:22 -0700
committerSam James <sam@gentoo.org>2023-07-16 14:25:46 +0100
commit35abb03226fa0c311425af975a67aca0dc99d179 (patch)
treecb65cd89b925f143ccbfa305d009aed20f597552 /dev-python/rtslib-fb
parentsci-geosciences/grass: bump development subslot version (diff)
downloadgentoo-35abb03226fa0c311425af975a67aca0dc99d179.tar.gz
gentoo-35abb03226fa0c311425af975a67aca0dc99d179.tar.bz2
gentoo-35abb03226fa0c311425af975a67aca0dc99d179.zip
dev-python/rtslib-fb: add 2.1.75
[sam: Not the latest version as submitter couldn't test 2.1.76 yet, and 2.1.75 fixes a serious bug over the current version in tree.] Closes: https://bugs.gentoo.org/903279 Signed-off-by: WXY <wxy@unreadableco.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/rtslib-fb')
-rw-r--r--dev-python/rtslib-fb/Manifest1
-rw-r--r--dev-python/rtslib-fb/rtslib-fb-2.1.75.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/rtslib-fb/Manifest b/dev-python/rtslib-fb/Manifest
index c52c5a43dfc1..e6b358b21b09 100644
--- a/dev-python/rtslib-fb/Manifest
+++ b/dev-python/rtslib-fb/Manifest
@@ -1 +1,2 @@
DIST rtslib-fb-2.1.74.tar.gz 73919 BLAKE2B d16527ed1efae379aa976929d8e6dd8a13cb1d47eb8efe8897ee495b0864225f520b42bd27fe502a1fad11369d20690b9751e54ae7a328c60917144114358d24 SHA512 b0b0722a5a7e10af698ae0570a65b51d7f091bfcc370850dacb3087471ca98bd229b4a5ed73760b7ed5bbee1b53dae4781cc2b3d5e7a1ff8ce37c5c144477852
+DIST rtslib-fb-2.1.75.tar.gz 74188 BLAKE2B 13fbeffb0396fa39d17362c05973572feab86eaa6748d4043f7721f3b631e670266dfbaebc26afb70e83547c4a24f149399d7d77725ecb9e9f6ac4ef709306d4 SHA512 b20109fd40cd0d23621bb01f884e302432a1dde98d0147dbd7a2eaf7a724801c77759effb26717b0451c5fb2f75e67287d9c0364c3c7ee3072d08cce259ce616
diff --git a/dev-python/rtslib-fb/rtslib-fb-2.1.75.ebuild b/dev-python/rtslib-fb/rtslib-fb-2.1.75.ebuild
new file mode 100644
index 000000000000..ab841c60c9ad
--- /dev/null
+++ b/dev-python/rtslib-fb/rtslib-fb-2.1.75.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="A Python object API for managing the Linux LIO kernel target"
+HOMEPAGE="
+ https://github.com/open-iscsi/rtslib-fb/
+ https://pypi.org/project/rtslib-fb/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit "${FILESDIR}/target.service"
+}