summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-01-13 22:39:26 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-01-13 22:39:58 +0700
commitf31c367c05e0894d626cd08e896b5c94c44bc61d (patch)
treee77d9b623c9ec7e7c7a13f127aa61f14a1d3482e /dev-python/rpyc/rpyc-5.0.1.ebuild
parentmail-client/thunderbird: REQUIRED_USE="wifi? ( dbus )" on 78.6.1 (diff)
downloadgentoo-f31c367c05e0894d626cd08e896b5c94c44bc61d.tar.gz
gentoo-f31c367c05e0894d626cd08e896b5c94c44bc61d.tar.bz2
gentoo-f31c367c05e0894d626cd08e896b5c94c44bc61d.zip
dev-python/rpyc: bump to 5.0.1
Closes: https://bugs.gentoo.org/761742 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/rpyc/rpyc-5.0.1.ebuild')
-rw-r--r--dev-python/rpyc/rpyc-5.0.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/rpyc/rpyc-5.0.1.ebuild b/dev-python/rpyc/rpyc-5.0.1.ebuild
new file mode 100644
index 000000000000..39488104ff23
--- /dev/null
+++ b/dev-python/rpyc/rpyc-5.0.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
+HOMEPAGE="https://rpyc.readthedocs.io/en/latest/
+ https://pypi.org/project/rpyc/
+ https://github.com/tomerfiliba-org/rpyc"
+SRC_URI="https://github.com/tomerfiliba/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# USE flags gdb, numpy are used *only* to run tests depending on these packages
+IUSE="test numpy gdb"
+RESTRICT="!test? ( test )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] dev-python/pandas[${PYTHON_USEDEP}] )
+ gdb? ( sys-devel/gdb )"
+
+RDEPEND="dev-python/plumbum[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+
+ # Windows specific test
+ rm tests/test_win32pipes.py || die "rm tests/test_win32pipes.py failed"
+
+ # These tests require running sshd
+ rm tests/test_ssh.py tests/test_deploy.py || die "rm test_ssh.py test_deploy.py failed"
+
+ # This test requires internet access
+ rm tests/test_registry.py || die "rm test_registry.py failed"
+
+ if ! use numpy
+ then rm tests/test_service_pickle.py || die "rm test_service_pickle.py failed"
+ fi
+
+ if ! use gdb
+ then rm tests/test_gdb.py || die "rm test_gdb.py failed"
+ fi
+}
+
+python_test() {
+ # for some reason, when tests are run via pytest or nose, some of them hung
+ pushd tests > /dev/null || die "pushd tests failed"
+ for x in test_*.py
+ do ${PYTHON} ${x} || die "${x} failed"
+ done
+ popd > /dev/null
+}