summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-28 17:12:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-28 17:18:53 +0100
commitc93f48b5c7f378e8f1e385ad7e0be7d862f1e45e (patch)
treebbed7de35ff76a749151a9b16b7eb2af8236c168 /dev-python/rich
parentdev-python/poetry-core: Bump to 1.5.0 (diff)
downloadgentoo-c93f48b5c7f378e8f1e385ad7e0be7d862f1e45e.tar.gz
gentoo-c93f48b5c7f378e8f1e385ad7e0be7d862f1e45e.tar.bz2
gentoo-c93f48b5c7f378e8f1e385ad7e0be7d862f1e45e.zip
dev-python/rich: Bump to 13.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-13.3.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index a6c76cfabaac..09be4988fcd8 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,2 +1,3 @@
DIST rich-13.2.0.gh.tar.gz 15066145 BLAKE2B 1a767de5d3b872e07e74374d956b4a3d1b6916a98846f98208f8a2e14a1c12f18fe7d85919f0b2104228fd74d25e640d446fae416a70254f7241fa726fb82802 SHA512 a3df2d3bdb35d25cad867cafad726a081d7fcba45e0b4ea2ec9aa17c28fc4d2c22f4ba1c7e3ef16fea7137c052875632b8d774895082d40804dc929021c0a2ef
DIST rich-13.3.0.gh.tar.gz 15055287 BLAKE2B bf314606d2da55d1c20d01083c21edc6f10590431152d360f1a5731fc543d47360faabd5141d3bf9b46793145a08bd79c971974ae85956df8821a33afa45bc50 SHA512 1ad28c6ea505ad4088ccab8a034b5ffa49f9ad59e7b60fe27dbcb8fec485f9f695d25dde83b102021c24ff149fdd9e981a1009bb82eb545250824436bd818d62
+DIST rich-13.3.1.gh.tar.gz 15055408 BLAKE2B 79713ee232bc1c990c1432f7966cffd69b8ffef9ad8a562339d62b03fbab4620040c5ae1d735d3084d71f32581955f0ea5fad113ff992dcddb2dd0e20465484e SHA512 a3b5bef2183bbb888f0ef5a90b35fdb1ed7ef6103dfea01a5efa441ce8d1769b53d7888684e3b5cd76bcacf3768835d918d9fbb7801eab57c04d1412f129f6bb
diff --git a/dev-python/rich/rich-13.3.1.ebuild b/dev-python/rich/rich-13.3.1.ebuild
new file mode 100644
index 000000000000..55b97b52578e
--- /dev/null
+++ b/dev-python/rich/rich-13.3.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ <dev-python/markdown-it-py-3[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.14.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ # pygments?
+ tests/test_syntax.py::test_python_render_simple_indent_guides
+ tests/test_syntax.py::test_python_render_line_range_indent_guides
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}