summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-15 09:47:39 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-15 10:04:20 +0200
commitc59950ca915b47b8eb0e1444f9d6df3aa418c2c9 (patch)
tree2066381d4aa43c015ce80da979af698634781c34 /dev-python/rfc3986
parentdev-python/rfc3986: Remove old (diff)
downloadgentoo-c59950ca915b47b8eb0e1444f9d6df3aa418c2c9.tar.gz
gentoo-c59950ca915b47b8eb0e1444f9d6df3aa418c2c9.tar.bz2
gentoo-c59950ca915b47b8eb0e1444f9d6df3aa418c2c9.zip
dev-python/rfc3986: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rfc3986')
-rw-r--r--dev-python/rfc3986/rfc3986-2.0.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/rfc3986/rfc3986-2.0.0-r1.ebuild b/dev-python/rfc3986/rfc3986-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..c9723f802429
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-2.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="
+ https://rfc3986.rtfd.org/
+ https://github.com/python-hyper/rfc3986/
+ https://pypi.org/project/rfc3986/
+ https://tools.ietf.org/html/rfc3986/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="idna"
+
+RDEPEND="
+ idna? (
+ dev-python/idna[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/idna[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest