summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-03 10:05:52 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-03 11:16:33 +0200
commit738d8af1ec010a59dff6800a5801f6e7395548e4 (patch)
tree021ed8bb1f13599ea63a7b4f308d564b4fdbb35d /dev-python/qtconsole
parentdev-python/websockets: Bump to 9.0.1 (diff)
downloadgentoo-738d8af1ec010a59dff6800a5801f6e7395548e4.tar.gz
gentoo-738d8af1ec010a59dff6800a5801f6e7395548e4.tar.bz2
gentoo-738d8af1ec010a59dff6800a5801f6e7395548e4.zip
dev-python/qtconsole: Bump to 5.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/Manifest1
-rw-r--r--dev-python/qtconsole/qtconsole-5.1.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index d605e4963b9a..98e267657310 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1 +1,2 @@
DIST qtconsole-5.0.3.tar.gz 428599 BLAKE2B 3110d597fe8692d46ac64c8f058f96356be62b95e74ebba8476eae148a9aa51193da0fe67fecf8a2de90d280121367802866bf17f68c7ad5b52ce3f84914af82 SHA512 efe88c66a508eac4ed14efb698b99d80b1a292e4b90fb04f76be829e95cf12b36e3afd968a6c7203bdd077a8bedbf7207c3a717809aaa3a514dfd99f7d4d5dcb
+DIST qtconsole-5.1.0.tar.gz 428856 BLAKE2B 4176c8add4fb949a82ce33fe9df598d2141c42dfa9ce57ae09ea201398df6ea54e00b890ad2b548b51e95f4dc0c7b2793640ced9b39b7adea910e3d2b90ec900 SHA512 50d2f1466d1fd5ebd33da1778f8271c5a328a61551f665e488c5c45326fabb4b431090d89b39c130a064b3c117cd24dc92e160c68c1eecf6647f2b662b01b2db
diff --git a/dev-python/qtconsole/qtconsole-5.1.0.ebuild b/dev-python/qtconsole/qtconsole-5.1.0.ebuild
new file mode 100644
index 000000000000..9fea2d480c04
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+BDEPEND="
+ test? (
+ dev-python/QtPy[${PYTHON_USEDEP},svg,testlib]
+ )
+"
+# required by the tests that are removed:
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/pytest-qt[${PYTHON_USEDEP}]
+
+PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+src_prepare() {
+ # TODO: these tests require virtx; however, running under virtx
+ # causes pytest to segv on exit (even though tests pass)
+ rm qtconsole/tests/test_00_console_widget.py || die
+ distutils-r1_src_prepare
+}