summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAidan Harris <mail@aidanharris.io>2019-02-13 17:57:13 +0000
committerSebastian Pipping <sping@gentoo.org>2019-02-18 17:40:15 +0100
commit2f91ace561dfa0079dd853c7a820e2065cbe5c8a (patch)
tree8ac714e7d5a872c3488f7f7c488ee49cc9cd9f66 /dev-python/pyxdg
parentsys-apps/sysvinit: Use separate sed command for logsave removal. (diff)
downloadgentoo-2f91ace561dfa0079dd853c7a820e2065cbe5c8a.tar.gz
gentoo-2f91ace561dfa0079dd853c7a820e2065cbe5c8a.tar.bz2
gentoo-2f91ace561dfa0079dd853c7a820e2065cbe5c8a.zip
dev-python/pyxdg: python3.7 support
Closes: https://bugs.gentoo.org/677892 Closes: https://github.com/gentoo/gentoo/pull/11041 Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Aidan Harris <mail@aidanharris.io> Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-python/pyxdg')
-rw-r--r--dev-python/pyxdg/pyxdg-0.26-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyxdg/pyxdg-0.26-r1.ebuild b/dev-python/pyxdg/pyxdg-0.26-r1.ebuild
new file mode 100644
index 000000000000..f8810a58d4ea
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.26-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
+inherit distutils-r1
+
+MY_P=${PN}-rel-${PV}
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="https://freedesktop.org/wiki/Software/pyxdg https://cgit.freedesktop.org/xdg/pyxdg/"
+# official mirror of the git repo
+SRC_URI="https://github.com/takluyver/pyxdg/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-themes/hicolor-icon-theme
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ nosetests -v || die
+}