summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-19 06:44:27 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-19 06:57:53 +0200
commit4727466244f46f053085da3d0b764dc68b4be5e4 (patch)
treef9746f8f6989b734566267cf89788d3ec50c14a5 /dev-python/pyupgrade
parentdev-python/zeroconf: Bump to 0.69.0 (diff)
downloadgentoo-4727466244f46f053085da3d0b764dc68b4be5e4.tar.gz
gentoo-4727466244f46f053085da3d0b764dc68b4be5e4.tar.bz2
gentoo-4727466244f46f053085da3d0b764dc68b4be5e4.zip
dev-python/pyupgrade: Bump to 3.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyupgrade')
-rw-r--r--dev-python/pyupgrade/Manifest1
-rw-r--r--dev-python/pyupgrade/pyupgrade-3.7.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/Manifest b/dev-python/pyupgrade/Manifest
index c632f19fbcc0..c5670ffcd816 100644
--- a/dev-python/pyupgrade/Manifest
+++ b/dev-python/pyupgrade/Manifest
@@ -2,3 +2,4 @@ DIST pyupgrade-3.3.1.gh.tar.gz 62720 BLAKE2B e1b1d899bb46871f0a28ac3423efbcbd91e
DIST pyupgrade-3.3.2.gh.tar.gz 62698 BLAKE2B 5dc1d9e9ea7b91cb2835ffdbc109fb4fcde629f375c49714cf52fe779b20a61f38f13321a14803636e759ac8a4460e768c4173c6608da1cf7cd44a3a347660e9 SHA512 6436286a9398d9cae8c5e9cff2104c43638cafb866a1b97794c1d20cadc078ae5a657d1b83512461d20d2f581b8f8fbbb2ee4d0516f8e75d562c5934be4966e5
DIST pyupgrade-3.4.0.gh.tar.gz 62408 BLAKE2B a816cea1e2b17790312d4e17ec972a1e09a0dd81c6fe4f7eb28c686b39b468b84190b26cf9ae5a711f70f8c1213c0b472975cc76339f64d2af4b4a8593af6b79 SHA512 cf9b8d8b430949eb0b49ec1b28576db7d6932c83a727660fe5e2cd61ae32e3efba63120580e0184931e3fdd4a4913a0f9cb37984ca83adeab05ab3ca57107b27
DIST pyupgrade-3.6.0.gh.tar.gz 62595 BLAKE2B a6622985e4b26bfb55cdeebd2323bd912289399bffa167b7d4ac1d16c11072b9b58793193febed31838d72691f3c6882914cd7005391f477a2ca6c78b808a33d SHA512 15b3ea59e0afbd5da0c2e7d60ed938d418107eb99cae7d2a5059fcea3f3ea69f451fed962cbdbb40655c39911c92f21bb9ace55f9b1bc65be2f8870b5b48acb8
+DIST pyupgrade-3.7.0.gh.tar.gz 62560 BLAKE2B 65715106db02e83f801b47aad5e48ba6e84cc42121298a210de8893752392ecbf99953fb6e0b7a2629b76e454523520794b7107226587d7dcfb46eecaad82439 SHA512 cd6b0a1516e91e1e8823333aaa314ca265387ea8dfb5739e428703f2dd798755126dc6269a5d253d6eaa3118d096945e9492f7f122ae306f6d5835b8aa9fa30f
diff --git a/dev-python/pyupgrade/pyupgrade-3.7.0.ebuild b/dev-python/pyupgrade/pyupgrade-3.7.0.ebuild
new file mode 100644
index 000000000000..8d3990592700
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-3.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="
+ https://github.com/asottile/pyupgrade/
+ https://pypi.org/project/pyupgrade/
+"
+# no tests in sdist, as of 3.3.2
+SRC_URI="
+ https://github.com/asottile/pyupgrade/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/tokenize-rt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest