summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 16:36:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 17:23:34 +0200
commit8a8e6eaad89556b21c782e38b47943ba6d01b130 (patch)
tree343917a4e308d87edc1e06967c1b5a26f4fc9607 /dev-python/pytrie
parentdev-python/flatbuffers: Use PEP517 build (diff)
downloadgentoo-8a8e6eaad89556b21c782e38b47943ba6d01b130.tar.gz
gentoo-8a8e6eaad89556b21c782e38b47943ba6d01b130.tar.bz2
gentoo-8a8e6eaad89556b21c782e38b47943ba6d01b130.zip
dev-python/pytrie: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytrie')
-rw-r--r--dev-python/pytrie/pytrie-0.4.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytrie/pytrie-0.4.0-r1.ebuild b/dev-python/pytrie/pytrie-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..f516fd30d597
--- /dev/null
+++ b/dev-python/pytrie/pytrie-0.4.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="PyTrie"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A pure Python implementation of the trie data structure"
+HOMEPAGE="
+ https://github.com/gsakkis/pytrie/
+ https://pypi.org/project/PyTrie/
+"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest