summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-29 05:01:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-29 05:26:18 +0200
commit446211e61f9eeef38ec2f73247f8e8b6b5dc5d65 (patch)
treed272410a59824aa555bdbadbbda477858b7581f4 /dev-python/pytools
parentwww-servers/caddy: Copy deps tarball to dev space (diff)
downloadgentoo-446211e61f9eeef38ec2f73247f8e8b6b5dc5d65.tar.gz
gentoo-446211e61f9eeef38ec2f73247f8e8b6b5dc5d65.tar.bz2
gentoo-446211e61f9eeef38ec2f73247f8e8b6b5dc5d65.zip
dev-python/pytools: Bump to 2024.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytools')
-rw-r--r--dev-python/pytools/Manifest1
-rw-r--r--dev-python/pytools/pytools-2024.1.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytools/Manifest b/dev-python/pytools/Manifest
index b614e0b8b54e..de282a6bf6a5 100644
--- a/dev-python/pytools/Manifest
+++ b/dev-python/pytools/Manifest
@@ -1 +1,2 @@
DIST pytools-2024.1.5.tar.gz 80774 BLAKE2B 37e9e14d5a62cdad34ddbfd0eabec747c392ba1506aacc76322f090699192369915882ba948fa07cd7a45369d3391343d9b2554def851e844976bc0442ddcfb6 SHA512 af7b79f1e26a43459765627ce6e6740953c38e05e26f3ec17360ccdf588ac320eabb5540fbbf9570cde324b8aae2412878316e9930e5195f467dbf5b74ca76b8
+DIST pytools-2024.1.6.tar.gz 81344 BLAKE2B ff68e2606170bf54e3f609ee7f4cfe58e063f43dcfb2706d5ed7659ea2fde863e6315d0d81dff2e62a3378f195413561a927b0c1e7bedc06388cf4893c07b873 SHA512 a9e934f1cbaf0ace32420f9b74224a06ce8421ee291b837292133969c6788c4cc8bea01446cd4d1505aca9fa81e8ae0d3eacf60d3285186e66d67d5abe10ce3e
diff --git a/dev-python/pytools/pytools-2024.1.6.ebuild b/dev-python/pytools/pytools-2024.1.6.ebuild
new file mode 100644
index 000000000000..38860936dd01
--- /dev/null
+++ b/dev-python/pytools/pytools-2024.1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="
+ https://mathema.tician.de/software/pytools/
+ https://github.com/inducer/pytools/
+ https://pypi.org/project/pytools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+
+# NB: numpy is now an "extra" (optional) dep -- we can remove it from
+# RDEPEND If revdeps don't need it
+RDEPEND="
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest